This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Nuvi 3590LMT - Windows 10 not seeing it

I have not used this for many months, just charged it now and again.

Today I wanted to update the maps using GaminExress but found that windows was not seeing the nuvi and I was unable to view the files.

Windows is set to view hidden files/folders and the unit is set as mass storage. I have installed the garmin usb drivers which were probably up to date anyway.

I have tried three different cables, two of which were new, each connected directly to the pc.

Any suggestions would be appreciated.

Comments

  • makem 96 Points
    edited September 18
    I have checked all three cables with my S8 phone using an adapter and none of them work! Seems they are for charging only,

    I did say it was many months since I used the nuvi. I will find a cable which can connect the S8 and see if the problem is solved.

    Linux is your friend. :)
  • alanb 529 Points
    This probably goes without saying, but I will mention it just in case ...
    Make sure you are plugging the USB into the nuvi 3590 itself and not into the cradle.
  • makem 96 Points
    Yes thanks I am aware of that.
  • makem 96 Points
    edited September 18
    Yes, it was the cables which were only for charging.

    I have thrown them all away as it is annoying to have to mark them in some identifiable way.

    I used Linux lsusb comand to determine they were just charging cables as I was just guessing with windows. I thought it may have been the 'April update' which caused the problem. I should have checked before posting from windows which I avoid using.

    Linux is you friend :)
Sign In or Register to comment.
↑ Top