This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Drivesmart 50 in a bootloop and the battery fails to charge

I got this unit about 6 months ago. It has been an excellent device, no complaints.

Last time I used this unit successfully was last week when I made a 2-hour trip. During this period, the device was plugged into the power source using its own charging cable. When I reached home, I noticed that the battery is discharged (the charging sign icon). It was surprising as the unit was plugged in all the way (it is always plugged in while in use due to the traffic receiver in the cable).

It is since plugged in and the car has run for more than 12 hours, still, it is not charged and is in a boot loop.

I did a reset by holding the power button for 12 seconds. Following is the video I did after a reset. After a few boot loops, the unit starts. I thought the problem is solved but within the next 10 seconds, it again went in a boot loop.



Does anyone have a pointer on how to fix it? I suspect there is some file corruption but I could not find reset option after it started. Maybe software reset will fix but no idea how to do it.

It still has Garmin's warranty.

Thanks in advance.

Comments

  • alanb 539 Points
    You definitely need to get the charging problem solved before you worry about file corruption. Have you tried using a different charger, like a wall charger or your computer? If it appears to be charging, let it charge for several hours, and then see where you are with boot up and file corruption.
  • teejay 91 Points
    Yes, tried both. I have Garmin specific charging cable. Left it for 24 hours, it didn't even go into the boot loop, just dead.
    Connected to the laptop but the screen doesn't light up with the computer connected logo, even after a couple of hours being connected to the laptop's USB port.

    The screen lights up only when connected to the car charger hence its in the car connected since Monday.
  • alanb 539 Points
    edited May 31
    It sure sounds like a hardware failure … either the USB port or the charging circuitry. in either case, it is probably not user repairable. Is the unit still in warranty? Whether it is or not, I would call Garmin support to see what they will do for you. I would suggest calling rather than trying to communicate with them via email.
  • teejay 91 Points
    Thank you.

    It is still under warranty. I will call them up today.
  • teejay 91 Points
    Just an update. Garmin sent me a replacement (refurb) GPS.
Sign In or Register to comment.
↑ Top