This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Spontaneous reboots with Drivesmart 55

I bought a new Drivesmart 55 and started getting reboots while navigating. Because of Amazon's return policy I sent it back and was sent a replacement. This one started doing the same thing. I called Garmin's customer support and they worked with me on trying to figure this out. They couldn't have been more helpful. They finally decided to replace my second unit with a third. So that was done and now it has happened again. But it seems to only happen when I'm navigating and using the Garmin app "Drive" on my iphone 8. I don't think I've ever had a reboot with Bluetooth turned off. Anyone else experience this kind of thing? Thanks.


  • privet01 231 Points
    Seems like someone else posted a similar issue. However I'd think that if more than one was doing this, then maybe it's a something with the power coming to the cigar lighter or power outlet in your vehicle. Might be a momentary voltage drop for some reason. Loose connection, corroded connection, charging system starting to go wonky, and etc.

    The thing about it not happening when you don't use the Garmin Drive Bluetooth app doesn't necessarily eliminate the issues with the vehicle power supply either. When using bluetooth, the device is using more power. So it is then more susceptible to the possibility of going below a threshold power that causes the reboot.

    However the result of rebooting also does not quite sound right for the above either. I don't think my drivesmart really reboots. It just goes to sleep, seemingly because it comes right up when power is re-established and after answering the liability disclaimer, continues the current planned route. I never see the splash screen with the loading software as I do with other garmin devices when I power it on. With the exception of updates and connecting to my computer.

    Maybe your devices battery is going dead because it's not getting enough power to charge. Possibly that forces a re-boot when power is re-established.

    Anyway..... let us know if any of the above was worthless, helpful or suggested other possibilities to you.
  • Maineac 2 Points
    My previous GPS, a Nuvi 54LM, was powered by a USB cord and I never had any problems with it. I have used both, the USB plug and lighter plug with these Drivesmart 55's and it seems to make no difference. I don't believe power is the issue.
    At this point, I don't have enough time with any of the three units to say for certain what happens when. My belief is that it is an issue with the Drive app and/or Bluetooth and if it is I won't be sending this unit back. I don't really need to use the app; it was a matter of convenience. And while I believe things should work the way they were designed to work, this unit is so good I will not complain if it is the app. But I intend to keep experimenting to see what shakes out and will report my findings here (if I remember to, I'm 71).
    Thanks for the response, privet01 .
  • MustangGT 42 Points
    I had a Garmin Drivesmart 65 for about a week, it rebooted on me once while I was using it. I returned the unit and I’m still using my Drivesmart 61. It started having the reboot problem only after upgrading to version 6 of the software. I never had the problem before that. I can’t pinpoint the exact conditions when it happens, but I always use the Garmin SmartLink software. It mostly seems to happen when I reach my first destination, but sometimes when I start the car and try to pick my first destination. Sometimes it’s a single reboot, sometimes it will continually reboot 5 or 6 times, and it then stops rebooting on its own. It seems to happen less often if I leave the GPS in the car instead of taking it out every night.
  • Maineac 2 Points
    Yesterday I waited for my wife at an appointment and sat in the car for about 30 minutes. At the beginning I entered a destination using the Drive app with Bluetooth. At about 5 minutes in the Drivesmart 55 rebooted and as it happened a screen popped up on my iphone asking me to choose a network. I had been reading a news story using cellular data. Anyway, I got the Garmin opening screens and my destination was still in there. Then it rebooted 3 more times in the next 25 minutes. This all happened while sitting still.
    At this point it certainly appears that the Drive app and/or Bluetooth is related to the rebooting. As you point out, MustangGT, you always use the SmartLink app (Bluetooth) and you experience rebooting. Thank you for responding.
  • MustangGT 42 Points
    They definitely introduced some kind of bug when they went to version 6 of the software. Unless they can reproduce the problem themselves while using a debugger or error logs, it looks like this problem will stick around for a while.
    I had a problem with Alerts not going away (e.g. Curve Ahead) when I first got the Drivesmart 61, and as with you, the first level support people are quick to recommend replacing the device. It took a lot of effort of trying to convince them it wasn’t a hardware problem and to pass the problem to the next level support. Eventually it got fixed two software versions later.
  • MustangGT 42 Points
    Drove from work to my 1st destination, about 20 minutes, pulled into the parking lot, 2 seconds later the Drivesmart 61 went into a reboot cycle. It rebooted 8 times in a row. It does a full reboot, you see the license agreements, then the warning/safety notice. Before I can even press the “Agree” button, it rebooted again, for a total of 8 times, and then it was fine for the rest of my trip. I was using the SmartLink app, but I turned it off on my iPhone, as well as Bluetooth at about the 4th reboot, and it continued rebooting.
  • OldGeezer 56 Points
    Software version 7.50 was released this morning for the DriveSmart 55. Maybe it will help your situation.
  • Maineac 2 Points
    Thank you, OldGeezer, for the heads up. I'll be loading that today to see if it helps.
  • Maineac 2 Points
    Hey, OldGeezer, I loaded Ver. 7.50 and now have 2 hours of Bluetooth navigation without a reboot. Yeehaa! That's the longest I've gone with any of the DS 55's. Maybe, it was the fix (fingers crossed). If I get a reboot with the new software I'll post it here.
  • MustangGT 42 Points
    I hope they release an update for the Drivesmart 61 that fixes the problem too.
  • OldGeezer 56 Points
    Glad to hear it Maineac. Hope it keeps working for you.
  • Maineac, has your Drivesmart 55 experienced any further reboots since you updated the software?
    My Drivesmart 61, still occasionally gets into a reboot cycle of 4-5 reboots. There’s been no recent update for the 61.

    I contacted Garmin, they sent me a refurbished Drivesmart 61, it too has problems, but slightly different than my original one. It has spontaneously shut down on me when I was driving, it shut down on me adjusting the brightness, but lately it can be fine for about an hour, and the suddenly drop to 40% brightness. If I try to increase the brightness, it says something like, use a proper cable..... After unplugging and replugging it back in a few times, it’s fine for a while. I’m using the original Garmin12 volt adapter. I’ve tried various chargers and cables, sometimes they work for a while, and then it misbehaves.

    I tried a Drivesmart 65 a few months ago, it too rebooted on me, also using its original cable. I returned the unit for a refund.

    I’m reluctant to buy the 65 again, unless I know for sure that the problem has been resolved. Garmin seems unaware of people having this problem.
  • Maineac 2 Points
    MustangGT, I have not had a single reboot since upgrading the firmware and I leave bluetooth on all the time. I'm pretty confident that the firmware upgrade fixed my particular problem. As to whether Garmin knows about this, I believe they knew about my problem (and I would bet many others with the same thing) but I believe they would never admit this. They just come out with a firmware upgrade and move on like nothing happened.
    Your particular problem(s) sounds to me like a hardware issue.
    Good luck with this and let us know the outcome.
Sign In or Register to comment.
↑ Top