This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Drive 50 won't connect via Garmin Express

Hi,
I always have difficulty connecting my Drive 50 to Garmin Express. I have tried a number of different cables. I tried turning the program off and on.

Any suggestions?

Comments

  • sussamb 813 Points
    When you say difficulty do you mean it eventually connects or it doesn't connect at all? Some devices do take a while to show in Express, often depending on how large the track log is.
  • flyyboyy 81 Points
    It does not connect at all.
  • flyyboyy 81 Points
    Thanks sussamb,
    I tried everything in the vid including restarting my Mac.
    I am running GE 6.16
  • sussamb 813 Points
    In that case follow the instructions at the bottom:

    If these steps did not resolve the issue

    Visit Related Content at the bottom of this page or the Garmin Express section of Support Center and you will find the available Product Support contact options in the Contact Us for More Help section.
  • teejay 91 Points
    Which USB cable are you using? The one that came with Garmin or a generic one. Generic one may not work depending on how it is designed. If you have Western Digital External Hard drive (in a WD enclosure), use that cable instead of generic one and see if it helps.

    Out of almost 20-25 mini USB cables I have, only 2 of them can detect the device on the laptop. All charge the device though.
    Just a few data points to figure things out.
  • sussamb 813 Points
    That's because they can either be data or power only cables, many that come with other devices are 'power only' :)
  • flyyboyy 81 Points
    Thanks sussamb,

    I tried your suggestions and no joy. I used the Garmin connection cable.

    I called Garmin and got a fellow who dissed my computer. No reason given. Every other thing on my computer works fine BTW, so I did not find his sharpness to be helpful.

    I ended up getting the GPS to connect to my PC and uploaded the info.

    I continued to explore the problem, changing USB ports with no luck. Then I changed to another cable which I had used before (one of 4 cables I tried and not a Garmin cable) and it connected. All of the cables had been tried a number of times and then spuriously this cable worked.
  • Kevin_hutch 65 Points
    Many have tripped over a low GPS battery try dimming your GPS screen and charging the GPS plus the way of differentiating power from data cables. Just when you think you have it nailed, it changes.

    As far as the USB world when you have some time try researching it in Wikipedia, you will find it is a minefield of variations within the standard with USB 1, 2, 3, 3.1gen 1 gen 2, PDS (power distribution standard) all on the same connectors then there is, USB Mini, Micro and their variants.
    Evolution is a wonderful thing, as is backward compatibility. Not just speed but voltage too up to 20 volts on that simple standard 5v connector with variations up to 5 amps and all standard.
    Now there is USB 3.2 and 4 on the C type connector to provide a new layer of adaptability and backward compatibility.
  • flyyboyy 81 Points
    The latest ver of GE seems to crash my computer sometimes when trying to connect my practically new Garmin watch using the supplied cable.
  • flyyboyy 81 Points
    Now my Colorado 300 will not connect.
Sign In or Register to comment.
↑ Top