This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

3590LMT not recognized by Windows on one computer

My Garmin 3590LMT was working fine to update maps in Garmin Express, but now, on one computer, it isn't recognized by Windows. Windows does recognize my other Garmin on that USB port, and another Windows computer does recognize the 3590LMT. I've tried different USB cables and different USB ports on that computer, and they don't make a difference.

Any suggestions on how I can get this Windows computer to once again recognize my 3590LMT?

Comments

  • alanb 555 Points
    Are you connecting in MTP mode (default) or Mass Storage mode? Whatever the case, try switching to the other mode. It should connect in either mode, but there have been reported cases where one mode works better than the other on certain computers.

    Also, try connecting the USB when the nuvi is already powered up, or if that is how you are doing it, try connecting when it is completely powered down (not in sleep mode). Again it should connect under any of those conditions, but sometimes changing it can make a difference.
  • Thanks, Garmin Support had me try Mass Storage Mode (I'd never heard of that), and that worked.
  • alanb 555 Points
    Glad you got it figured out.
Sign In or Register to comment.
↑ Top