This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Problems with TomTom Home

I have a TomTom XL330 and am running MacOS 10.13.6 (High Sierra) on a MacBook Pro. This morning when I connected the TomTom to the Mac and launched TomTom Home (version 2.11.7.575), I received a dialog saying that there was a critical update to version 2.11.8.747. I tried doing the update several times, but each time I ended up with version 2.11.7.575. Finally, I did a clean uninstall of TomTom Home; and then 2.11.8.747 was installed. However, when it ran, it said there was a major upgrade and that that version was no longer usable. I then installed the new version (2.20.9.1273); but when I try to launch it (by double-clicking on the application), nothing happens.

Consequently, I can no longer update the QuickGPSfix.

Comments

  • dhn 336 Points
    Others have reported the same issue on Tomtom's production forum. So far, TT has not responded.
  • dhn,

    Thank you for your response. Unfortunately, the discussion that I found on the TomTom site was primarily related to Windows and not Macintosh.
  • I think I have come up with a solution for the Macintosh. I first installed TomTom Home 2.11.7.575. I then did:

    1. Control-click on TomTom HOME in the Applications folder, and select Show Package Contents.
    2. Click the triangles next to the Contents folder and then next to the Resources folder.
    3. Select the Resources folder and enter Command-I.
    4. Click on the lock symbol at the bottom-right of the Resources Info window, and then enter the system password.
    5. change the Privilege from Read only to Read & Write for everyone.
    6. Repeat steps 3 through 5 for application.ini within the Resources folder.
    7. Control-click on application.ini and select Open WIth\Other...
    8. Select TextEdit and then Open.
    9. In TextEdit, change "Version=2.11.7.575" to "Version=2.99.99.999".
    10. Close the file in TextEdit.
    11. Change the permissions for Resources and application.ini back to Read only for everyone.

    I was then able to run TomTom Home without being prompted to upgrade to a newer version, and I updated QuickGPSfix.

    (I first tried this with TomTom Home 2.11.8.747; but that version still insisted on doing an upgrade.)

    I'm not thrilled with this solution, and I would rather have one done by TomTom; but having something that runs is better than something that doesn't.
  • dhn 336 Points
    Good work there.
Sign In or Register to comment.
↑ Top