This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Garmim Express will not "Find" my Drive 6 device

I just went to update the maps on my "new" Drive 6LM for the first time and no matter what I do, Garmin Express cannot seem to find the device.

I did a search ere and the only one that seemed relevant mentioned 2 ways to view the device when the computer couldn't find the GPS, but in my case mt computer finds and loads the GPS and it's the Garmin program that can't seem to find it.

I just updated my Garmin Express program last night (per notification) and proceeded to updated 2 of my Garmin Nuvi GPS devices successfully. Win 7 IOS.

When I plug my Drive 6 into my computer (using a Genuine Garmin USB Cable) and my computer finds and recognizes the device and loads it, and it appears as a storage device under "Computer". I have previously had problems using non-Garmin cords to connect my device for updates (the cords will charge and power the GPS but will not allow the computer/Garmin program to recognise it) which is why now I only use Garmin cords (they have "Garmin" moulded into the computer end.

The screen of the Drive 6 shows the computer Icon on its screen while connected as it should, but despite "Searching" for my Drive 6 MANY times ("Add a device", then "Search" when it doesn't find it).

The device works perfectly, and I just wanted to update it because newer maps are available. On suggestion said for Garmin Express to work you need a fully charged GPS battery, and I used a genuine Garmin charger (has a fixed cord and USB plug) I had from long ago to charge the battery, but no difference. :(

Any "tricks" to get the program to recognize my device?



  • Boyd 2028 Points
    When you say "it appears as a storage device under "Computer", it's not clear to me whether you have actually switched the GPS to mass storage mode. On Windows 7, the default will be to mount it as an MTP device, and that would look about the same however it wouldn't permit access to the system files that Garmin Express needs. Here's an explanation of how to enable mass storage mode, if you don't already know.

    Now, I have used Windows 7 will all my Garmin devices with no problems, but others have reported that they needed to manually switch the device into mass storage mode. So try that if you haven't already.

    Another problem to check for is a corrupt GarminDevice.xml on the GPS. This file is automatically generated each time the GPS starts up, and it contains info about its capabilities that Garmin's software needs to access. I've read that manually deleting this file can fix odd problems sometimes.

    But I'm not a fan of Garmin Express and rarely update my devices, so others here will probably know more about this.
  • bobinyelm 182 Points
    Thanks, but I tried to follow the instructions at the POI Factory, and it says press and hold a finger at the top right corner of the Volume screen (the screen I get when I press "Volume" on the initial page where "Where to" is located.

    At the top right of my Drive 6 page is an image of a camera which I think just takes a screen shot.

    I tried pressing it for 10 sec next to it and only heard a camera click (and other places on the volume page) but no Developer's Page comes up.

    I note in the first paragraph of that linked material it says that MTP is used on the following devices. Garmin Drive units mentioned are:
    Garmin Drive 40, 50, 60, but my unit Drive 6 is NOT mentioned.

    On deleting the file you mention, how would one access and do that?

    For anyone reading this thread, here is the above-linked MTP procedure:

    Some automotive devices use Media Transfer Protocol (MTP) for connecting to your computer. MTP provides a more secure environment for the important system files on your device.

    MTP connectivity requires the following.

    Windows XP with service pack 3 or later.
    Windows Media Player 11 or later.

    The following devices use MTP mode:

    The Camper/RV 660, 760, dezl 570, 760, 770, dezlCam, Garmin Drive 40, 50, 60, Garmin DriveAssist 50, Garmin DriveLuxe 50, Garmin DriveSmart 50, 60, 70 series, Garmin DriveTrack 70, nuvi 55, 56, 57, 58, 65, 66, 67, 68, 2405, 2407, 2408, 2505, 2507, 2508, 2509, 2609, 2707, 2708, 2709, 3400, 3500, 3507, 3508 series devices, nuviCam, zumo 350, 390, 395, 590, and 595 devices use Media Transfer Protocol (MTP) for connecting to your computer. MTP provides a more secure environment for the important system files on your device.

    If the above system requirements are not met, or you are using the device on a Mac, the device will connect to the computer using standard mass storage mode instead of MTP mode.

    To change to Mass Storage. Example, using Nuvi 2597.

    1. Bring up the volume screen on the GPS.

    2. On the upper right hand corner. Press your finger on screen and hold for appx 10 seconds.

    3. Shortly you will see the developers screen.

    4. Find MTP Settings and touch it.

    5. It will show 3 selections. MTP Auto Detect,Mass Storage and Mass Storage Single Session.

    6. Touch Mass Storage as your selection.

    7. Now select save and you are good to go.

    Some additional information provided by JD4x4.

    Accessing the Garmin RV660 MTP mode screen.

    "From the map display screen, touch the lower left "Speed" display area,then press and hold the "speedometer" area on the speed/status screen. This brings up the Diagnostics Page, and touching the Configuration and Settings bar brings up the MTP Settings bar".

    See also
  • bobinyelm 182 Points
    Thanks- I tried the link and it did nothing because in the upper right, I have only a camera symbol. I could never get a developer's screen.

    But I tried plugging my device into my computer and doing nothing else.

    Suddenly (after about 2 minutes) Garmin Express opened all by itself and announced it had found a new device and to click "+" to add it.

    BINGO, I was IN!
    (or so I thought)

    It downloaded new software into the Drive 6 then said download complete, and to unplug the device, wait 10sec, and plug it back in to allow the new software to take effect. Now my Garmin Express says my Drive 6 is NOT connected and it may take "A few Minutes" to connect.

    10 min later it has failed to re-start.


    But at least it got PART way, though it might be locked up if I cannot finish the process.

    I'll let you know...
  • bobinyelm 182 Points
    I unplugged the GPS after waiting at least 10min and a couple of minutes later it re-booted with a Garmin Logo and under it a spinning symbol below which it says:

    Installing update files.
    This may take several minutes.

    No matter what I do or how long I wait before plugging it back into the computer, or shutting the unit down and re-staring it, it is now locked in the above mode telling me : "This may take several minutes."

  • Boyd 2028 Points
    edited January 2020
    Whew, that's quite a story and unfortunately I don't have time to really follow along. Just a few quick comments.

    * All Garmin automotive units from the past or 8 years or so are MTP devices. The Drive series is definitely MTP.

    * The camera icon means that you have screenshot turned on. Is there some reason for this, or did you turn it on by mistake? It can be turned off in the display settings.

    * It sounds like you finally downloaded a firmware update but it did not correctly install for some reason. We touched on this topic a couple days ago here:

    Hopefully you'll get things sorted out.
  • IF you still wish to have the screenshot camera on then there is a second way of accessing the MTP menu by going to the map screen, tap the speed then hold the speed this takes you to the same diagnostics page scroll down to MTP settings and select Mass Storage.
  • sussamb 947 Points
    bobinyelm said:

    But I tried plugging my device into my computer and doing nothing else.

    Suddenly (after about 2 minutes) Garmin Express opened all by itself and announced it had found a new device and to click "+" to add it.

    It can take a while for Windows to recognise a device, you'll know it has happened as File Explorer will open, at that point Express will see it as you've discovered.

  • bobinyelm 182 Points
    Yes, in fact!

    My Nuvis get loaded by Win7 very quickly (seconds), but the Drive 6 takes a LONG time before I hear the Win7 "ding"alert telling me the device was configured.

    I also found the Garmin Express program is set to start when Windows "sees" a Garmin device has been loaded (the box allowing this was checked).so I didn't realize it would have self-started.

    With the Nuvis I always had Garmin Express already running when I connected the Nuvis to the computer.

    I finally found Garmin Express would ONLY "find" the Drive6 if I allowed the program to self-start after Win7 recognized the device. If I had the program running in advance when I plugged the GPS in, no matter HOW LONG the device was plugged in later, it would not find the GPS either automatically or by searching for it, and I tried searching for it more than 15 minutes after Win7 configured the GPS.

    Finally i realized this "quirk." I don't know if this is by design or just happenstance.

  • Boyd 2028 Points
    edited January 2020

    IF you still wish to have the screenshot camera on then there is a second way of accessing the MTP menu

    The trick of pressing the speedometer worked on my old Nuvi's but I could never get it to work on my new devices. But really, nothing the OP has said indicated that he needed the screenshot function. So I'd guess he turned it on by mistake. We had another thread here where somebody thought the screenshot function was a camera and complained that he couldn't find any of the "pictures" he took,. :D
  • bobinyelm 182 Points
    RE: Screenshot Feature

    I never turned it on, or ever used it (Frankly, I didn't know it had an On/Off function), and again frankly we only even used the GPS exactly as it came out-of-the-box, so we didn't explore any of the menus, assuming they were enough like my earlier Nuvis, but with a larger screen and better lane guidance for my wife (in whose car it sits).

    I think the "secret" was that the Drive 6 takes MUCH longer for the computer itself to recognize it, like several minutes, vs only a few seconds for the older Nuvis, and by not taking enough time for that, and by searching for it in Garmin Express too soon, I assured that it would never find it, as it may have stopped Win7 from finding and configuring it.

    Eventually (like a LONG time later) the device updated it's software program and accepted Map Updates, and now appears to be working fine. Interestingly, the MAP update on the Drive 6 was MUCH faster than for my older Nuvis (which can take 2 hours even on 100+mb/sec internet speeds, since the download speed shown in Garmin Express is usually about 2mb/s.

    My wife likes to find businesses in the Garmin database (rather than looking up the business in Google and then using the address in teh GPS as I do), so has been sent to a closed business more than once, so we tried updating the Drive 6 to update the POI files within it. I find even the NEWEST Garmin updates are frequently WAY behind with regard to POIs, so I tend not to rely on them exclusively.

    Thanks to all who answered-
Sign In or Register to comment.
↑ Top