This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Oregon 450T

Since a recent Garmin Express update my garmin has had issues.

1 with the existing card it starts to boot then just fades after 10 seconds
2 without the card it boots OK
3 with a newly formatted sd card it boots OK\
4 with open streetmaps file it worked and I was able to boot
5 tried with my purchased OS map - failed as before
6 removed OS file and just left openstreetmap file failed again

Any ideas?

Comments

  • muffinn 83 Points
    I have tried factory reset - no change
  • muffinn 83 Points
    and OSm file no longer selectable
  • sussamb 829 Points
    If you're sure it's due to the update, assuming it's a software update, you could try reverting to an earlier version?
  • muffinn 83 Points
    Might be coincidental. I have been able to get OSM on again but then I change to a geocaching profile and it wont start again
  • sussamb 829 Points
    Well I'd try reverting to see if the issue still exists. If it doesn't you'll know it's the update, if it does then the fact it happened around the time of the update is coincidental and you'll need to look for other causes.
  • muffinn 83 Points
    How do you revert?
  • Boyd 2010 Points
    edited June 3
    See this page for info about different firmware versions. Assuming it is up to date, looks like the last firmware update was February 2014. There's a link on this page with instructions for installing the firmware.

    https://www.gpsrchive.com/Oregon x00/Versions x50.html

    ------------------

    "Normally I would recommend upgrading through Webupdater but if for some reason you can't (e.g. you are trying to downgrade) then you can update using the following procedure:

    Use the links below under "Software Version" to download the gcd file for the version you want to use
    Change the name of the file you just download to gupdate.gcd
    Attach the Oregon to your computer and verify that it is in USB Mass storage mode
    Copy gupdate.gcd to [OR drive]:\Garmin\gupdate.gcd
    Restart the Oregon"
  • alanb 557 Points
    I have had this same issue with my Oregon 550 when I had seven Garmin BirdsEye (.jnx satellite image) files enabled. If I removed any one of them it would boot normally. I also had a 3 GB OSM .img street map file enabled, but removing it wouldn't resolve the problem. It would only boot if I removed one of the .jnx files. I never figured out exactly what the problem was, and eventually just gave up on using the BirdsEye files.
  • muffinn 83 Points
    I've been told my SD port is broken - just ordered a new GPS after 10 years - not too bad
  • sussamb 829 Points
    That was going to be my guess if reverting didn't help
  • Boyd 2010 Points
    That would explain it. But do you really mean "SD" - in other words, the slot inside the GPS where the card goes? Or do you mean "USB" - the interface connector on the outside? If it's the SD card slot, take a close look. It might just be bent or dirty contacts, or some foreign material. These might be easily fixed. I would also try another SD card, just in case that is the problem.

    But yeah, it's time to move on from the 450. Great device in its day, but very slow processor by current standards
  • muffinn 83 Points
    Thanks. Yes tried the cleanin pins and checking shapes and another card. Gone for a 700
Sign In or Register to comment.
↑ Top