This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

'no map data available'

Was working OK yesterday, but following an update on Garmin express last night I have this message today
is this repairable please?

Comments

  • brookes 2 Points
    Should add, Garmin Nuvicam
  • First, power all the way off, then power on and try to reinstall the map.

    If that doesn't help, check in settings to see if the map is installed and enabled. This link may help with the steps to do this. https://support.garmin.com/en-US/?faq=0lxtbhtWQB6ilbUV2C3zn6
  • brookes 2 Points
    Thanks but I have tried both restarting and read through that Garmin link this afternoon.
    Garmin Express still says it's all in order so I've reinstalled GE as well for good measure
  • sussamb 941 Points
    Use Garmin Express to reinstall the map.
  • brookes 2 Points
    Actually, GE is where the problem began, I noticed Nuvi was a little behind on roadworks and speed limits so updated it with GE.
    it apparently worked as it should and announced all was up to date only to discover the next morning in vehicle it had 'lost; its maps.
    Last night I again used GE with same result, uninstalled and reinstalled GE to be sure I had newest version but it proudly announces still 'you are up to date' but no maps... (I took a screenshot, but don't seem to be able to put it up here, probably as a new member I expect)
  • brookes 2 Points
    Guessing this might have to be one for a repair centre going on response, I was hoping it might have been something could have been tackled here, thanks for ideas anyway
  • sussamb 941 Points
    GE should give you the option to reinstall the map even if your map is up to date, are you not seeing that?
  • brookes 2 Points
    I'd post a screenshot but I'm not permitted can I message you it instead?
  • brookes 2 Points
    edited November 14

    image

    image
  • brookes 2 Points
    Doesn't show but click on links
  • Boyd 2027 Points
    Fixed that for you. :)

    To display an image, click the little "picture frame" icon in the toolbar and paste your link into the box.
  • brookes 2 Points
    Thank you, my regular hosting Co is offline at the moment anyway
    I >think< I may have found the reinstall option mentioned earlier though its not perhaps obvious TBH,
    Presently the Nuvi is hooked to Mac and downloading (something) in an hour I'll know if it was successful and try and string together a couple more screenshots
  • sussamb 941 Points
    If you find it it'll be under Map Options
  • brookes 2 Points
    OK I *think* I've got maps back :)
    I was hoping to post screenshots of Garmin Express of how I achieved it but going back now I'm not seeing the same path
    (probably as I've re-instated the maps)
    but it's roughly;
    Home screen>
    Tools & content>
    Utilities> (scroll down for reinstall maps)

    a further screen opens showing progress bar as maps re-install,


    Mine took nearly 2 hours but appears to have completed and Nuvi works,
    I'll take it to work on Monday and report back if anything amiss

    thanks for help
  • Another path would be to select your device in Garmin Express and click on "Map Details" on the main screen where it shows "You're up to date!" That will take you to a screen showing the installed map(s). Click "Map Options" under the map description, then on the Map Options screen click on "Reinstall Map."

    Same result, just a different way to get there.
  • brookes 2 Points
    Handy, useful resource here certainly, especially as only recourse otherwise would be a repair centre, wonder how I managed to delete its map in first place.

    I have used GE previously on same model Garmin, that one has developed a technical fault where it essentially flicks between functions all by itself as I drive along, may be able to get it repaired I don't know, but I can't be without a device as I use it in my driving job almost all day.
  • For the GPS that "flicks between functions all by itself" you could try a factory reset.

    Start with the device turned off and unplugged from power. ...
    Power on the device.
    When the first copyright screen appears press and hold the lower right hand corner of the display portion of the touchscreen.
    Remove your finger from the touchscreen when "Erase all user data?"

    If that doesn't work, call Garmin and ask for estimates to get it fixed or replaced. Might be cheaper (and more reliable) to buy a newer model GPS and a dashcam.
  • brookes 2 Points
    Is this a known issue, symptoms look like an invisible digit is choosing screens at random,
    or
    I am trying to add a postcode (for example)
    the touchscreen reacts to my fingertip but the device doesn't actually begin searching the postcode
  • Just guessing. I haven't heard of this before. However, a factory reset can sometimes solve things when there is no other obvious solution. Be ready to reload ALL of your saved data and settings. Just guessing. Like chicken noodle soup when you have a cold - it might help, it might not help, but it shouldn't make things worse than they already are.
  • brookes 2 Points
    Well, original Nuvi is a couple of three years old now so may be too old but with a spare here now I'll try a restart or perhaps send it in for repair depending on who's working over lockdown
  • Boyd 2027 Points
    brookes said:

    Well, original Nuvi is a couple of three years old now

    Garmin discontinued the Nuvi line in 2015, so it is probably a bit older than that. :)
  • brookes 2 Points
    Pity I like the inbuilt camera its useful, mine has software supposedly 2018 according to loading screen and so does the replacement unit I've recently bought.

    Does anyone know of another unit with camera fitted with wide screen, I'll need to buy another I expect later on
  • You might want to look at the driveAssist 51 and driveAssist 50. You can find details about them on the Garmin site under automotive "previous devices and models." They are available on line for a lot less than the Garmin price. The dezlCam 785 and RV 785 also have built in dash cams, larger screens and higher prices.
Sign In or Register to comment.
↑ Top