This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Maestro 3100 not recognized via USB

schilcur 0 Points
edited November -1 in Magellan Vehicle Forum
To All,
I'm trying to update the firmware and when I connect my 3100 I get an "unrecognized device" error. When I check the specific port in the device manager it tells me there's no driver. Driver update doesn't find a driver. Any suggestions?

Thanks,
Schilcur

Comments

  • After messing with it for about an hour I tried powering down the unit, then connecting the USB, and powering up. That got the computer to at least recognize the unit. I did, however, get an alert stating that the unit was not connected to a high-speed usb port. My desktop is about 4 yrs old so I may not have high-speed ports. I was able to complete the firmware update, took about 40 minutes to complete.

    Hope this helps someone with a similar situation.

    Schilcur
  • patruns 10 Points
    What version of Windows are you using? Although Magellan says it will not work with Vista........... it will. When I plug it in Vista sees it as another drive and the SD card as another removable drive. I too am using older USB 1.1 ports so that does indeed slow down the process.

    Glad it worked out for you. For anyone else, I would recommend that you turn the unit on first, but leave it on the blue "OK" screen. Then connect it and the screen should change telling you that the USB is connected.
Sign In or Register to comment.
↑ Top