This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Magellan 1200 Satellites

timetrek 0 Points
edited November -1 in Magellan Vehicle Forum
My magellan has stopped tracking satellites. For the last two days I have tried to route to different places and the unit still acts like I am still at the address of origin. I checked the statellites tracking information and it shows no satelites and tracking of 0. Has anyone run into this problem with the 1200 yet? I have tried it on the road, outside, inside and it still will not see any satellites. HELP!

Comments

  • Tim 1481 Points
    How long did you leave it on for while outside not moving? You might want to try these satellite acquisition tips and if it still doesn't help I'd (gulp) contact Magellan support.
  • I have had it outside and on for about 1 hour and it still cannot pickup the satellites. About two days ago it was perfectly fine. I have used it for about 2months I travel by car quite alot and all over the country and did not have this problem. It just kinda stopped tracking all of a sudden.
  • Tim 1481 Points
    I'd hit the reset switch and if that still doesn't help I'd call Magellan.
  • You may try to cut out the "middleman" in India, and just buy a new one swap it with the defective one and return it that way. I know it sounds a bit crummy, but so does how Magellan customer service handles problems, based on what I see in this forum.
Sign In or Register to comment.
↑ Top