This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

3D vs 2D Position/Icon Lag

When driving or routing in 3D map mode I usually notice some position lag (50-150 feet estimated as it varies) when passing intersections/side streets and after making left or right turns. However when I switch to 2D map mode the lag disappears or is so minor that it's not really noticeable.
Does anyone have any idea why this happens? Please try it...I bet it happens with your GPS.
Another observation I know I'm not crazy but some days the 3D position lag is worse/better than others. One day it seems spot on, then next day the lag is back.
BTW, I do NOT have any problems with the voice/TTS instructions/turn ding. They are always accurate/spot on regardless of 3D or 2D map.
Thanks for any feedback
Phil (4220)

Comments

  • This is my suspicion. I believe that Garmin has added some compatibility for free traffic, intending to offer it to the 7x0's. Part of that will involve advertising that may appear, and only when stopped. I think there is a resource call kicking in when you get within 2/10th's or so of a possible stop (redlight/destination arrival), asking the nuvi for a poi seach for sponsored content. Non-TTS voices require few resources. TTS on the other hand requires substantial memory calls. A combination of the open poi search and TTS announcements are maxing out the 7x0 processor.

    Just a guess of course.
  • What about Magellan Maestro/Roadmate units?
  • Hmmm.. .
    Guess I wasn't paying attention this morning and thought we were in the nuvi forum. My bad :lol:
  • Yes my 3100 started doing the lag thing after I did the firmware update to 2.18 on their website.

    I never use the 2d mode so I dont know if mine still does it when its in that mode.

    anyway, I wrote magellan many times about this and everytime they said to just use the relocate the gps function in the options menu. I did and it never stopped.

    They finally agreed to have me send it in for "repair". It should arrive for them on friday. I'll let you know what happens when I get it back. They said 7 to 10 days repair time, but after all the "my gps has been in for repair for 3 months" threads I dont count on getting it back anytime soon
  • Even thou my specifics were for another device in my earlier post, the general problem would be the same. Something added via the last firmware is likely using more processor resources than before. 3D is a bigger resource hog than 2D. That's probably why you aren't noticing the lag in 2D. Similar to what's affecting some nuvi 7x0 owners after a recent firmware update. Non-TTS voices and/or 2D mode eliminates our position lag.
  • Just got a email that my gps is on its way back from being repaired for this issue, It was not there for very long....Im hoping they did more than just reinstall the software.

    I let you know if they fixed the problem or did anything to it beyond fix the 2.18 software
  • wyd 0 Points
    I noticed mine lags just a little, not really been a problem though. I have been switching back and forth between 2D and 3D and it lags about the same in both modes. I do have the latest firmware update. I just can't remember if I had the same lag before I updated or not.

    I use my 4250 so much that it is second nature anymore and to be honest I don't pay total attention to it, just enough to get me where I'm going. :D
  • PND4ME 0 Points
    Try holding the power down for MORE than 10 second, unit is not releasing the memory. Need to have it reset to clear the memory out.

    2D takes less resources.
  • Just got it back took it for a spin, nope nothing has change, still has the lag problem. All they did was reinstall the same damn software.It cost me $16 for them to do nothing. I'm writing a nasty letter back.
  • PND4ME 0 Points
    Just got it back took it for a spin, nope nothing has change, still has the lag problem. All they did was reinstall the same damn software.It cost me $16 for them to do nothing. I'm writing a nasty letter back.
    Hate to say it, but the Maestro 3100 is one of the lower end unit you can probably buy for less than $99, why spend the money on it, but a newer model PND and be over with it.

    Processing speed is much faster now.

    With your issues with the icon trailing, I think you may have other issues like poor GPS receiption etc, not sure. Have you tried your unit in another car to see if it react the same way?

    Good Luck
  • Just got it back took it for a spin, nope nothing has change, still has the lag problem. All they did was reinstall the same damn software.It cost me $16 for them to do nothing. I'm writing a nasty letter back.


    Hate to say it, but the Maestro 3100 is one of the lower end unit you can probably buy for less than $99, why spend the money on it, but a newer model PND and be over with it.

    Processing speed is much faster now.

    With your issues with the icon trailing, I think you may have other issues like poor GPS receiption etc, not sure. Have you tried your unit in another car to see if it react the same way?

    Good Luck
    What does price have to do with the fact they told me they could fix it and didnt do anything to it that I couldnt do from my computer. FYI I paid $79 for it at target. I have tried it in multiple cars. Its a software issue, they just dont want to issue another firmware update. The original firmware worked perfectly and you cant even go back to that.
  • PND4ME 0 Points
    Just got it back took it for a spin, nope nothing has change, still has the lag problem. All they did was reinstall the same damn software.It cost me $16 for them to do nothing. I'm writing a nasty letter back.


    Hate to say it, but the Maestro 3100 is one of the lower end unit you can probably buy for less than $99, why spend the money on it, but a newer model PND and be over with it.

    Processing speed is much faster now.

    With your issues with the icon trailing, I think you may have other issues like poor GPS receiption etc, not sure. Have you tried your unit in another car to see if it react the same way?

    Good Luck


    What does price have to do with the fact they told me they could fix it and didnt do anything to it that I couldnt do from my computer. FYI I paid $79 for it at target. I have tried it in multiple cars. Its a software issue, they just dont want to issue another firmware update. The original firmware worked perfectly and you cant even go back to that.
    Take it back to Target!!! If what you stated is true, than EVERY Maestro 3100 would have the SAME issue as you have indicated since they are ALL using the same firmware / software!

    I guess since you claim it is the software that is causing your issue, than either every Maestro 3100 owner would be expierencing the same issue OR you could possibly have a problem with your HARDWARE? which would requires a warranty or hardware exchange.

    For $79, you could have purchased another one instead of shipping it back for $16 and doing without only to be disappointed.

    I don't think is Magellan fault, I think it is an END of LIFE product that you are expecting perfection out of it. Was it a refurbished unit, if it was, than you may already have your answer.
  • Target does not sell refurbs. Like I said, it didnt have the problem until the firmware update, look at other threads on multiple gps boards and you will see this problem is not limited to just my unit. Magellan caused the problem with the software update, and we all know how many units were bricked by the update process.

    also I just noticed that although I sent the unit back to magellan for "warranty" work like you said I should...............magellan didnt do the service, they outsourced it to some company called "thales Services".
  • Tim 1481 Points
    The former parent company of Magellan was Thales Navigation, so they are not really all that "outsourced".
  • What really makes me mad is that there is a firmware update beyond 2.18, Im sure they addressed this problem in the new firmware but they wont release it to their website because they want you to shell out 80 dollars to get it with the map updates.
  • PND4ME 0 Points
    Target does not sell refurbs. Like I said, it didnt have the problem until the firmware update, look at other threads on multiple gps boards and you will see this problem is not limited to just my unit. Magellan caused the problem with the software update, and we all know how many units were bricked by the update process.

    also I just noticed that although I sent the unit back to magellan for "warranty" work like you said I should...............magellan didnt do the service, they outsourced it to some company called "thales Services".
    Map updates that cause the units to be useless is MOSTLY caused by issue such as low battery power, other applications being open while updating etc. Mostly user error!!
    Thales is the French company who sold the Magellan GPS division to Shah Capital Regardless, if you have the problem than ask Magellan to send you a unit with the older firmware or sell your unit on eBay for $!
Sign In or Register to comment.
↑ Top