This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

7100 after update cannot see the card

cbssys 0 Points
edited November -1 in NAVIGON Forum
so I pushed reset. No luck. I reformatted the card and did a reinstall of the update and it still says to insert the card. It was fine before that. HELP?

Jim in Chicago


  • I N F OI N F O 0 Points
    Hey Jim,
    I’m not trying to be facetious, but could swing by Navigon and see about addressing your issue and then advise this community about the outcome. This will help to bring a lot of clarity to the Navigon saga. Here’s their last known address.

    NAVIGON Inc.
    200 W. Madison St., Suite 650
    Chicago IL, 60606
  • Spyder63 331 Points
    Save your gas and call this number: (312) 268-1500. Knock yourself out with the system directory.

    Maybe ask for one of these guys:

    President for the Americas Michael Roach
    Chief Executive Officer Egon Minar
    Vice President OEM Sales Gerhard Mayr
    Vice President Operations Edgar Christen
    Director of Product Support Steve Giunta
    Director of Consumer Sales North America Matt Corich
    Product Manager Kevin Yount
    Software Manager-Mapping Database Kerry White
    Channel Marketing Mgr. Ken Goebel
    Automotive Jens Nitzschke
    R and D Michael Kaufman
    Senior Software Engineer Richard Malingkas

    Here is another address to check out:

    Navigon Inc.
    200 S Wacker Dr 3130 Ste 3130
    Chicago, IL 60606 USA
  • Larry75 0 Points
    I was having the same issue, lost my original SD card. Navigon customer service was totally useless. Lots of reading on this site but fixed my unit. This is what I did.

    Go to Navigon site, download Navigon Updater Ver 1.2. The web page might ask you if you want both secure and unsecure. Select no. I tried yes but it would never download. Finally after several attempts I selected no and it Downloaded.

    The first five times I tried to install the program to my SD card I also kept getting the message Insert card.

    After the failed attempts I formatted the SD CARD FAT32 rather than default NTFS.Installed the updater software. WORKS PERFECT!

    Good luck, hope this works for you! :lol:
Sign In or Register to comment.
↑ Top