This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Updates for 1470 not working!

glennatheaxe 0 Points
edited November -1 in Magellan Vehicle Forum
I have tried to update the maps to version 39. The control manager update is fine, but I cannot get all the way through the updating--it stops at 1 minute remaining on the unpack and verify map screen. I have uninstalled and reinstalled the CM multiple times. No Joy! I was sent another site from which to get the files, but it turns out it was the OLD files. Great service--not!
Please help!


  • elvisfan 0 Points
    I installed with no problem. I don't know what to tell you. Except, make sure your unit is fully charged and wait a little longer at the end.
  • Thanks for the reply. I have reinstalled and uninstalled five times, waited over 10 hours the last time with a fully charged unit. I am sending the unit back for a replacement as now it is in the "please restart your unit for maximum performance" loop.
  • freds 0 Points
    If you do a search on this forum you will find some people have problems installing 2.22 and some do not. My update worked with no problems. BUT, afterwards I found that the vehicle indicator lagged my actual position. I would be going down an off-ramp and the GPS would notify me to turn, the "ping" came after I was on the off-ramp, not before. The position marking is off so that I am past an intersection before the map shows me at the intersection. I did not notice this problem before upgrading to 2.22.

    Magellan only says they will pass on the info to Engineering. This is part of the response I received:

    I suggest you delete the old software from your computer, redownload it and install it in your unit again. Use XP SP2. Let us know if anything changes.

    What I can do for you is have that forwarded to our Engineers so they can investigate if its a defect or was caused by the update. If that's the case, I'm sure they'll have a fix for that.

    Another option that I can give you is to call our Technical Support Team. The number is 1-800-707-9971, from 6am to 5pm PST (Monday to Friday). Choose option 3 for technical support and follow the voice prompt for your unit. They can effectively assist you regarding your technical inquiries.

    I don't use XP, on Windows 7, so not sure about that comment. I have an older 1470 as it does not have the 3-way switch. Only has an on-off switch.

    The other things is that you are forced to us Content Manager for upgrades. You cannot re-download an update if you have already updated your GPS. Content Manager says there is no update for your unit.
  • i get a similar issue, i have tried several times to update to the 3.11 software on my 1470, and each time i do with the new content manager (which i hate, btw, id much rather download the update myself and install it the old fashioned way, ive even asked Magellan about it and they offer no help) but the update CTD's about 1/3 of the way through the actual software install after the unzipping. and to make matters worse, now all i get when i turn on the GPS is the magellan screen for a few seconds then it shows a screen of a computer and what i assume is the GPS unit linked by a USB cable...when i have it disconnected there is a red X in the GPS's screen on the picture. does anyone have any ideas or even better, know of a place i can download even older software just so i can get it running and try the update another way?

  • Contact Magellan and tell them you want the FTP sight. There is one available. It can get you back to 2.22 of the firmware. Be firm. The first person I spoke to told me no. The second person told me yes. You will install it the old fashion way.
    By the way, what version of Windows are you running? I had the same problem. The install would just stop. Same signs on the screen. If you install and have no voices. Just do the reinstall again.
Sign In or Register to comment.
↑ Top