This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Garmin nuvi 260 Reset required?

My Garmin nuvi 260 may be corrupted.
When turn on, it is jumping between Garmin logo and Loading map, but failed to load map.
Also, the Garmin could not be recognized by my computer any more.
Should I reset my Garmin nuvi 260? How to do it?
Anybody can help me to save my Garmin here?
Thanks.

Comments

  • Boyd 1985 Points
    This is most often caused by a corrupted map file, and the fix is not easy since the Nuvi doesn't have a hardware reset button. On these old models, a corrupt map file causes the boot process to hang (as you describe) and USB disk mode is not initiated.

    Basically, you need to hack the firmware to get the nuvi back into USB mode and then you can attempt repair. However, if you don't have a full backup of the unit you may be in trouble. If you have downloaded a map update in the past year, you can probably restore it using your account at garmin.com. Otherwise, it would be just as cheap to buy a new nuvi as purchasing a new map. :(

    We don't usually get into topics like hacking the nuvi firmware here. I suggest you do a google search for nuvi cure rgn and that will point you in the right direction if you want to attempt it.
  • Spyder63 331 Points
    Boyd - u da Man! Thanks for the rgn cure clue. I got a friend's 2460 into the same rebooting loop as the OP. I was pretty sure it was due to a corrupted splash screen bmp file I had modified and after setting up a cure.rgn to bypass all bmp files the gps booted and was recognized by the PC. All I had to do then was eliminate the splash screen file and we were back in business. It certainly was a mental exercise, but rewarding in the end. :) :)
  • Boyd 1985 Points
    Hey, glad that it worked for you. :)
  • I have tried to push RESET button, it shut off the unit but never back on. I also tried to turn off the unit, then hold pressing each of four corners and slide the switch to left and keep there, the prompt is always "Press dot" for calibration. What can I do now? Does "nuvi cure rgn" can solve the problem? Please help!
  • Spyder63 331 Points
    The "rgn cure" worked for me and it sounds like you should investigate it further.

    I'm not sure I would consider this "hacking" as all you are doing is temporarily stopping certain types of files from loading (such as .bmp, .img, .gpx, etc.) and this allows the gps to boot. You eliminate the problem file(s) and re-install your original rgn file and update as necessary - possibly your maps, firmware, a vehicle file, splash screen, if needed, etc.

    I did not have to do any updating for my problem which was a corrupt splashscreen.bmp file. The 2460 I was working on already had the latest firmware and maps installed.
Sign In or Register to comment.
↑ Top