This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

why won't my computer recognize my device (garmin 255w)



  • BJ_CT 0 Points
    Too many acronyms but I hope this is an intelligent question. After I do these steps, will I still be able to download with Basecamp (since everyone sez Mapsource will be going away when the world ends in December)? Is there an advantage in NOT switching to Mass Storage? Thx.
  • Boyd 1999 Points
    Mapsource is not "going away". It just isn't being updated anymore by Garmin. They will have to keep it around though, because Basecamp can't access handheld devices with serial interfaces. Believe it or not, Garmin still sells at least one model with a serial interface!

    Changing the setting to Mass Storage will not affect Basecamp or anything else. Evidently Garmin did this with the new models to prevent people for accidently deleting files.

    I think you should make this change regardless, so that you can backup your nuvi as described in that thread.
  • BJ_CT 0 Points
    OK. Useful information. Will do. Many thanks. :D
  • Same problem but with a few add ons.

    Had a nuvi 2460 which worked in it's own manner, just getting to learn how to use it after 3 months and a total failure, wont switch on or will and does nothing.

    Replaced with a different 2460 (know it was not the same as bought the second nuvi 2460 before I returned the first).

    Second closed down in a similar manner after 2 1/2 months, decided the nuvi 2460 and me didn't get along.

    Bought a nuvi 2595 which from the off suited me fine. More intuitive, logical and faster.

    To the point. Have been using mapsource to pre-write routes, downloaded them to both 2460's, but the 2595 wont accept routes from mapsource.

    Using the 2460 and 2595 original usb leads, also a Lindy cable too, makes no difference just get the same message " There was a problem communicating with removable media.

    Used a desktop with Win 7 located in France, a laptop with XP while in the UK, makes no difference.

    Try loading older routes that were written with 2012 mapping, no difference. Try using 2013 mapping no difference.

    Decided to load the micro card while fitted to the desktop with a route, no problem and no problem reading it when fitted back into to the 2595.

    Try loading MC when fitted to the device, no chance.

    Here's the rub. Wrote a simple route with base camp and this transferred easily to the 2595.

    Next read here that the mapping software had changed and that newer GPS did not recognise the mapsource software (maybe I have this wrong but what happened to backward compliance or whatever it is called).
    I didn't think that the 2460 was an old gps, the last one I bought at the end of May 2012.

    So although it has different software to the 2595 surely the part that allows transfers routes is the same in both models, or maybe it isn't?

    So, if I want to write routes for the 2595 with mapsource then I have to transfer them to the micro card, then just clip that in. Have I got that right?

    For what it's worth a 29 hours trip with numerous addresses and waypoints was accomplished almost without realising I was using a gps, now that is what I call a great device as it was seamless. I like the 2595 a lot.

    For my self I need to add lots of addresses and via points on my routes. My routes are never duplicated, I don't go to the same address twice. Many of these addresses are in tiny villages or hamlets, I have to use several map sources sometimes to define where the client is, I could do this easily with mapsource providing I had the info, can I do this easily with basecamp?
    I can't afford to get lost as all my calls are timed, mess up on one and the whole lot comes down like a pack of cards. For me it is reliability and keeping it simple, just to get from A to B with the least fuss.

    So if I and many others can't get a nuvi model to work with map-source just tell us. We may not like it but at least we will know. If there is something we are doing wrong then please tell us, we are not the specialists that you are, keep it simple.

    Have spent an entire day trying to sort out how the route that I plan can be transferred to my new gps, that's a day I couldn't work at my business, and as everybody else I need every day to keep it going.

    Have tried a bit with base camp and find it illogical and taking the pee out of the paying customer. I always thought that every new generation is supposed to take the product forward, but some of the basic automotive actions that were simple to perform in mapsource have now become complex or not possible at all. If it's good for the hand-held clientel then use it only on the hand-helds, don't mess up a simple straightforward piece of operating software that most of us know how to use.

    The amount of times I have heard " I only want it to work and do simple things , like get me from A to B without drama or needing a computer degree". Garmin wake up before you lose it.
  • Boyd 1999 Points
    Sorry, you completely lost me. Are you asking why Mapsource doesn't work with your 2595? If so, then the answer is in my post at the top of the page, along with instructions on how to change it so that it will work:
    Mapsource would not recognize the 3490, recognizes the Zumos just fine.

    The reason why Mapsource won't recognize the 3490 is because it's not a USB disk, it's an MTP device. Mapsource cannot access the \Garmin\GPX directory to read or write files. Basecamp is new software and it does know how to access the 3490.

    But you can change this - see
    How to backup your Nuvi
    I just received my received my 2595 today and did the backup of the NUVI when I received it. Here is the procedure I used.

    Make NUVI DIR & Files visible for Backup
    1. To make all of Nuvi files visible you must unhide protected files via Win7 like any other HD.
    2. Start NUVI by itself and go to Volume Screen.
    3. Press the upper right hand corner of screen for 10 seconds.
    4. The Developers Screen will pop up
    5. Scroll down to MTP SETTINGS
    6. Change from AUTO DETECT to MASS STORAGE
    7. Shut down NUVI and hookup to Computer USB cable
    8. Start NUVI and it should recognize it is hooked up to the computer.
    9. Explorer will now see all files in ROOT directory and the .System directories.
  • Boyd, I was having a rant in frustration, this is my 3rd new Garmin in 6 months, not the best advert for the company. It's not directed at you or any that try to help on these forums. What you do is excellent, but my view is Garmin appear to have lost the idea of what a gps is supposed to do well, get you from A to B without fuss.

    You are asking me to manipulate my computer / gps so that a brand new device can work with an older piece of software, shouldn't Garmin arrange this before they sell the thing? make it backwards compatible?

    I thank you for the info but may not do this. I am not a software engineer, I do have other talents that software engineers may not have. I don't ask my clients to overhaul their new whatever to make it compatible, as the supplier I would do this for them.

    If I get this wrong will Garmin ok the repair at their cost do you think?

    Sorry for being so grumpy but a bit fed up with the constant change which sometimes feels it's change for change sake.

    Thanks anyway, I do appreciate you taking the time.
  • popej 57 Points
    What you do is excellent, but my view is Garmin appear to have lost the idea of what a gps is supposed to do well, get you from A to B without fuss.
    Actually this is what nuvi does without problems. In my opinion,Garmin is trying to make a simple device, that doesn't need anything more than defining single destination. I agree with you, that Garmin has damaged many advanced features to get this aim, including routes.
    You are asking me to manipulate my computer / gps so that a brand new device can work with an older piece of software, shouldn't Garmin arrange this before they sell the thing? make it backwards compatible?
    Probably not. They offer new programs like BaseCamp, new features like Audible support and compatible devices. They prefer to sell you Audible instead of Mapsource and this could be a reasonable business choice. I don't like it either ;)
    I thank you for the info but may not do this. I am not a software engineer, I do have other talents that software engineers may not have.
    You don't have to be a software engineer to use nuvi menu. This is simple task, certainly no more complicated than managing routes on nuvi. I think the attitude you present here is the main reason for Garmin to dumb down their devices. No menus, no options, just put your destination and go.
    If I get this wrong will Garmin ok the repair at their cost do you think?
    I believe they will. Replacing not working units is what they do well.
  • Using another USB cable worked for me. It's really annoying to encounter this error and I'm not sure why it happens. My other USB cables are fine and I've never had any other issues with other devices.
  • larrainez 0 Points
    Okay .. after pouring over all the discussion and trying to determine the issue for at least a year (off and on)... Terrigirl had it!! (for me, anyways)
    The problem, was the space that the drive didn't have. It was full. By deleting most of the foreign languages that were filling the drive, it allowed Webupdater to "write" whatever it needed to, to the drive, and thus it found the device. I was able then to get all my updates!!! A huge breakthru and I wonder why it hasn't been discovered as a "FIX" before Terrigirl mentioned it. Thank you, TERRIGIRL!!!! You're my "hero-ess".
  • cdflyer 0 Points
    After spending several days and hours trying to update my nuvi 3550, I finally took a break to research it on the internet. My computer would not detect or see the GPS no matter what I did. I tried every fix I found online. Alas, nothing worked. I was about to dig thru a whole bunch of packed boxes to find all of my electronic gadget cables. (I was using the short cable from my Nook eReader for this task and was about to accept that I needed the original Nuvi cable.) I decided to try one more thing that I had tried once but had no success. AR316 on 23 Oct 2011 suggested deleting anything found in Device Manager under Portable Devices. I tried, but didn't even have a 'Portable Devices' category. This time, on the second try, I did have the 'Portable Devices' category because my nuvi was connected to the computer. And the nuvi was showing there. I deleted it. Then my computer automatically saw the nuvi connected and re-installed the software for it. I went to Garmin Express and selected Updates. They were found instantly and downloading and installation was accomplished a little while later. The cable was no problem. My updating software was no problem. No browser was a problem. (How could a browser affect any of this?) It just took a little simple fix that actually should not have been a problem either, but was. Thanks, AR316.
  • Hi All:
    Read through tons of suggestions because my Garmin Nuvi 1490 isn't recognized. Not on my PC. Not on my MAC. Tried everything I was told. Even bought a new Garmin cable. Phoned support and they said if that didn't work I'd have to buy a new GPS! That can't be right. I can't remove unwanted languages because it's not recognized. Removed Garmin Express because it's rubbish. What have I missed, without being toooo technical please? Should I just go out and spend more money on another device?? Thanks for your help.
  • sussamb 829 Points
    I assume your GPS is booting and working normally?

    Are you sure the second cable you tried was working properly? Have you tried different cable combinations on someone else's PC?

    If so then sounds like you have some hardware fault inside your 1490, and may well be time for a new one although if it's working then you could just keep using it :cry:
  • Hi sussamb - thank you for your reply! Yes - booting and working normally. I haven't actually tried it on someone else's PC but I have the opportunity to do that next week probably so will check with both cables. I have a feeling the bit at the back - where you plug in the USB has toasted! Darn! Thanks again. :(
  • mdmm 0 Points
    Had similar problem of no connection between Garmin nuvi 255W with PC.
    I bought a new USB cable from Walmart for 3 dollars and took out SD crad from Garmin nuvi.
    It detected,connected and i updated eveything using web updater
  • I have a new Nuvi 2797, which connected to my computer (Windows 7), no trouble and downloaded the updated maps.

    Now it is not recognized by the same computer. Also the same for my laptop (Windows 8) and also for an older computer (Windows XP). Nothing.

    It does not show in My computer, on any computer,yet whenever I plug into a usb port (either usb 2 or 3) it turns on.

    So far I have tried every usb on three machines, front and back (no used on hubs).

    I have downloaded and installed all the programs from Garmin including their updated usb drivers, but nothing helps.

    Now for the good news. It is only three weeks old and the shop asked me to return it and get my money back.
  • Tried all the steps in the FAQ-no success.
    Tried it in friends computer-no success. Returned to supplier-they tried it on their computer-no success.
    Thought I would upgrade ton the latest model but found it also has the same problem.
    They supplier have replaced it and will try the new one. Hopefully this will work.
  • sussamb 829 Points
    Should do. Very unusual to get one that doesn't.
  • Had the windows does not see the device problem on widows 7. In my case I checked device manager disk drives with my nuvi 1390 plugged in with garmin usb cable. No nuvi listed but there was a weird named (sorry I forget name) flash drive listed. Unplugged the device confirmed the flash drive vanished, plugged it in again and it reappeared. Uninstalled this device including drivers and rescanned for new devices. This time it loaded nuvi garmin flash drive with downloaded drivers. Once completed lo and behold Garmin Express fired up and downloaded and installed new software and maps. Nuvi device now recognised by windows 7. Hope this helps others.
  • psoon said:

    This problem is widely reported in more than one forum. The difficulty of a computer to detect a Garmin device when its connected via a USB cable is happening to both PC and Macs. Its happening regardless of whether you are using Win XP, Vista or Win 7 and any of the Mac OS.
    What is Garmin's response? Update your software! Duh, how do I update the software if my computer cannot detect the device!!
    I've had this happen to four nuvi models, where it'll be detected some of the times, but mostly not.

  • I had a Garmin nuvi 2597 and Windows 10. My computer would not recognize the Garmin at all. I finally had to send it back as I'd done everything everybody suggested. I've noticed in other blogs that many people have had this problem, but mostly with the Windows 10 update, not if the PC came with it preloaded. Any explanations anyone?
  • sussamb 829 Points
    My Win10 was an update from Win7 and all Garmin stuff works fine.
  • My Nuvi 350 worked and updated perfectly until last week when I attempted to download and install a map update via Garmin Express. When I plugged the Nuvi into my computer, the computer icon appeared on the Nuvi screen and connected to Express, after which I received a message that I needed more space and to install a SD card into the Nuvi. I unplugged the Nuvi, installed a 4G card, and plugged the device back into my computer. This time the computer icon did not appear on th Nuvi screen. Instead the Nuvi turned on and attempted to load the map. Halfway through the loading process the Nuvi froze. I am using the factory USB cable that came with the device. Although neither of my computer/s (laptop and desktop) do not recognize the Nuvi is plugged in, I have read on this forum that Garmin designed the 350 not to be recognized. Even though I charged the battery, I’m wondering if it migh be bad. I have no way of telling because the device won’t boot. Any help would will be appreciated.
  • Boyd 1999 Points
    edited December 2017
    Do a search for "garmincure3", it will take you to a thread on gpspassion. It's a program designed to help when the Nuvi isn't recognized by your computer. This can get very technical and complicated however.

    OTOH, the 350 was the first Nuvi model and was originally introduced in 2005. That is getting really old in terms of consumer electronics devices. :)
  • Boyd:
    Thanks for your suggestion. And yes, my 350 is old, but up until last week it worked perfectly. I don’t use it often anymore, more of a walking around guide when I’m in a new town or city. Both my cars have GPS so I’m not dependent upon the Nuvi. That said, I really like my Nuvi and though I only use it a few times a year, I’d like to keep it operating awhile longer.
  • alanb 556 Points
    Have you tried rebooting with the SD card removed? When you say it won't boot, what are the symptoms? Is anything shown on the screen or does it stay completely black?
  • I’ve tried rebooting with and without the SD card. Same result: when I power on the screen displays the startup screen with the version info, etc., then it goes to “Loading Maps.” Then around halfway through the loading process the device freezes up. I have tried to manually boot it by holding down the power-on switch, but it still freezes up when it tries to load maps.
  • alanb 556 Points
    edited December 2017
    Sounds like a corrupt file. Garmincure3 may be your only solution. Do you have full backup of your 350 ? Even an old backup will help. Cure3 can reflash the software, and once that is done, Garmin Express can reload the maps and some of the files, but you may need a backup to recover some missing files after you run Cure3.
  • Boyd 1999 Points
    Will Express restore the maps for an old device like that without a lifetime subscription? Not so sure about that....
  • alanb 556 Points
    edited December 2017
    No, but he said he was performing a map update with Express when the problem occurred, so I assumed he has a map update subscription or purchased a map download.

  • I have a lifetime map update subscription. I have never (intentionally) backed up my 350, but my laptop contains numerous Garmin map update files. I’m currently looking at Cure3 as a possible solution. I’m an old man and my learning curve is a little slow.
  • alanb 556 Points
    I have never had to use Cure3 myself, but I have read about it in many forums. As Boyd said, it is a very complex process. Many have used it successfully, but some have totally bricked their devices by trying it. I guess if your device is already trashed you don't have much to lose by trying. One of the best write-ups I have found was on the POI Factory forum. I normally don't link to posts in other forums, but I think this one is worth looking at, so I will give it. If the moderators think it is inappropriate, I guess they can delete my post. Here is the link:

    I wish you luck in recovering your nuvi 350.
  • alanb,
    I checked the POI forum and the instructions for Cure3. Much easier to folllow than instruction I’ve read elsewhere. Think I’ll give it a try. Many thanks.
  • alanb 556 Points
    Great. Just make sure you get the correct software file for your 350. Don't use the file for the 765 shown in the POI Factory post. You should be able to find the correct file for your 350 on the Perry archive.
  • Can anyone give tell me where I can find a downloadable”garmincure 3 file?” Everyplace I’ve tried tells me “The file . . . doesn’t reside here anymore.””
  • alanb 556 Points
    edited December 2017
    @fred38 ... I think I have a copy of it I can send as an email attach. GPS Review doesn't allow PM's. but if you are a member of POI Factory, you can PM me your email address over there (user ID alandb).
  • sussamb 829 Points
    I think you can pm. Click on the user's name and enter your message in the activity box.
  • alanb 556 Points
    edited December 2017
    Yes, you can do that, but not sure it is "private", so I don't think I would call it a PM. Maybe it is private, but I have seen messages sent to other users this way ... not sure exactly how it works.
  • alandb: Okay, I’m now officially registered on POI Factory. However, I don’t know how to post a PM (private message) to you from there.

    Thanks again
  • alanb 556 Points
    edited December 2017
    @fred38, I have received your PM and emailed the Cure3 file to you. There is a waiting period over there for new members to use the PM feature, but the admin forwarded your address to me.
  • Does anyone have access to, or know where I might locate, a Nuvi 350 gcd file? I’ve search the Perry archives, and everywhere else I could think of, without success. Thanks.
  • Boyd 1999 Points
    It's all there, hiding in plain sight in the Perry archives:

    Choose the version you want, such as nuvi350_540.exe
    Install 7-zip on your computer if you don't already have it:
    Right-click the nuvi .exe file and choose 7-zip > Open Archive
    Open the nuvi folder, then open the enclosed Garmin folder
    Voila! You will see the GUPDATE.GCD file. :)
  • Thanks Boyd. Alanb sent basically the same info. If I understand the Cure instructions correctly (and I probably don’t), Cure treats both the 350.exe and GUPDATE.gcd as sepertate steps when running the Cure program.
Sign In or Register to comment.
↑ Top