This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Firmware update without battery?

I've got an old Garmin Nuvi 750 with a dead battery. It works fine with the car adapter. I'd like to update the firmware but the webupdater says to make sure the battery is fully charged. I did read up a little about making a USB charging cable by shorting pinX to pin4 but I'm a little chicken to try the update if there's a possibility of bricking the GPS. Has anyone tried this before? Is there a certain order to do things that works?

Thanks

Comments

  • popej 57 Points
    I did once update of nuvi 3760 on phone charger. I don't think it is any base to conclude that your nuvi would work too.

    You should flash it on PC using firmware converted to rgn and Updater.exe
  • Amazon (and others) sell battery replacement kits for nuvis. I bought one for my 765t a while back, and the surgery went well. Not sure if the 750 uses the same battery, but there's a good chance it does. It doesn't take a great deal of skill to do the replacement, the tricky part is splitting the case apart. The replacement kit supplies a thin, rigid plastic shim that works well for that step.
  • I've used replacement batteries before from ebay and I've had the unit open to remove the bad battery. I was just looking for a method to upgrade the firmware without having to buy a new battery since I don't actually need the battery to use the GPS.

    Are there any instructions about how to do the upgrade using updater.exe and the converted rgn file? I seem to be missing that in my searching.

    Thanks
  • I went ahead and tried the update with the battery removed and the modified USB charging cable and it worked. Once the webupdater finished I ejected the GPS which powers it off since there's no battery and then connected it to my modified charging cable. It proceeded to start and do the update. I'm pretty sure I could have used my car power cable instead and it would have worked.

    Thanks for the help.
Sign In or Register to comment.
↑ Top