This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

CN NA 2014.40

CN NA 2014.40 is now available according to a post on the Garmin forums.


  • sussamb 936 Points
    For those wishing to update there is also a new version of Garmin Express out ... v2.4.4
  • hardwire 181 Points
    Just downloaded from:
    but the properties show the file version as
  • hardwire 181 Points
    Looks like if you install 2.3.18 then check for updates it finds the update... :)
  • Anyone know if GarminMapUpdater still works with this update, for luddites like me? :D
  • hardwire 181 Points
    Mapupdater did not work for me so I'm trying express... :(
  • mapupdater is not working for me either because it only gives me the option to buy the new map and not update.
    I am downloading the EXE file from Garmin site to see if theres a new version that works otherwise I might have to install express. :(
  • sussamb 936 Points
    If MapUpdater suggests you need to buy the map just click where it says 'I have a product code'. You can get that when you log into your myGarmin.
  • Tried that but it gives me an error and it quits. Express it is then... :(
  • sussamb 936 Points
    This is strange, users on the Garmin forum are also reporting issues with MapUpdater and CN NA 2014.40 ... but it works fine when downloading CN EU 2014.40.
  • Sunrise 101 Points
    Garmin Express is now up to version
  • sussamb 936 Points
    Crikey ... that's a quick update as 2.4.4 only came out a few days ago, may explain some of the problems folks are having.
  • DerekW 232 Points
    Downloaded and installed latest US maps - it took about 40 minutes to down load and then much longer to get the data onto the SatNav. I used the Garmin Map Update program on a Mac.

    Still get the block on accessing French towns unless the US maps are disabled in the device.
  • t923347 533 Points
    Had a problem with MapUpdater as it said there was an server issue and couldn't continue. The last 2 updates reported that there was a map update to PURCHASE but I have Lifetime Maps. Fixed that as sussamb suggest above by getting the product code from

    Went to my backup plan which was using Garmin Express. Doing this in the past resulted in GE reporting that my 3597 did not have enough space for the full North American update. Much to my surprise, this time I got no such message and the update went without incident although I have no idea why it wants to download the update twice. The first download installs the maps on my Nuvi while the second installs it on my computer. MapUpdater may have done this when selecting install to device and computer but hid it from the user so it looked like one download. I have no idea about that.
  • sussamb 936 Points
    edited February 2014
    The full jcv file for the CN NA 2014.40 map, for those that require it, is now available here

    Size is 796.76MB
  • GarminMapUpdater does not download the map twice if you chose the option to install on the computer.
    I couldnt download the map last night with GE so I will try mapupdater tonight again hoping that Garmin fixed their stuff.
  • t923347 533 Points
    Your right if you only install on the computer both GE and MapUpdater only download once.

    If you pick the option to download to the device and the computer then I'm not sure how you can be sure that the download doesn't happen twice when you use MapUpdater.

    I used Garmin Express successfully for the first time yesterday and it took about the same time to complete the update as it has always taken for the MapUpdater update. With Express you actually see the download happening twice. With MapUpdater you only see the single update bar progressing. So if that MapUpdater progress bar is taking the same time to get to 100% as GE takes to download the update in both download bars, then it's possible, as I've said above, that MapUpdater does exactly the same as GE but doesn't show it happening.

    Pure speculation on my part because with MapUpdater you can't see what's happening with the download but with GE you can and the net result is that it took about the same time to do this update with GE as it has in the past with MapUpdater.
  • i think I know what you mean by downloading twice. I think one of the downloads is Basecamp and not the actual map again.
  • t923347 533 Points
    I think one download is "for" Basecamp/Mapsource and I know that the first download goes on the device as I checked the contents of the .system folder on the Nuvi after the first download completed and the second one had started.

    The first download reads:

    Full Coverage of North America 2014.40

    The second download reads:

    nuMaps Lifetime North America 2014.40

    After I checked that the new files were on the Nuvi and before the second download finished, I checked in both Basecamp and Mapsource and 2014.40 was not listed. After the second download completed 2014.40 was available in both software programs.
  • sussamb 936 Points
    I can confirm one is the download to the device, the other the download to the PC for Mapsource/Basecamp.
  • I've never had to enter a product code for my lifetime maps before, but in case I'm prompted this time, I just want to verify which code to use.

    On, under manage maps, there is a list of all updates I've installed with my lifetime map update card. Under each update is a "code" (8 alphanumeric characters) and an "unlock code" (about 500 characters). Each code is different, even though they've all been installed using the same lifetime update. Do I just use the 8-character code that appears under the most recent (2014.30) update?
  • t923347 533 Points
    8 alphanumeric characters is the one you'll need.
  • Sussamb you are telling me that GE downloads twice the maps instead of just once and then install it on the Nuvi and then Computer?
    What a waste of bandwidth
  • alanb 557 Points
    Garmin Express shows it as separate processes while MapUpdater showed it as a single process. But I am with T923347 on this. Garmin Express finishes in about the same time as MapUpdater did, so I suspect they are performing similar processes.
  • Zemartelo 207 Points
    edited February 2014
    Finally installed with GE on my 2555. It had to install to the SD card as there wasnt enough room in the internal memory.
    I will be able now to see if there is a visible hit in the performance of the unit from having the map in the card.
    I didnt find an option to just install US+Canada map. Is that gone with GE, by skiping Mexico the unit probably would have enough room.

    Anyway the only thing that it puts on the card is the map itself, all the other files stay in the internal memory (JCV, SID files, Traffictrends, etc)
  • sussamb 936 Points
    GE does offer a choice but it's not obvious. It's under the Device tab ... Look for Advanced Options.
  • sussamb 936 Points
    edited February 2014
    Ooops ... no sorry, that's now just for where to install the maps, so you can choose GPS, PC or both. There is a button that gives the option to Change Regions. I find that choice can be quite limited though, so if necessary install to PC then select the maps you want. Be careful though if you have a GPS that does voice recognition as there are limitations on what mapsets you can choose, see here:{1df288e0-19f9-11e0-d39a-000000000000}

  • For the past 4 years I have been using MapUpdater to install maps to my Nuvi 1350 and 1490T. It appears that this option is no longer available so this morning I installed GE ver and installed the latest map update to my 1350. It took about 40 mins to install to the device. Installation went okay but I just wish the MapUpdater was still an available option but could not find it anywhere.
  • sussamb, Thanks for providing the link. I appreciate it.
  • t923347 533 Points
    It's still available but many people are reporting that it doesn't really work well, or at all, anymore. In my case all I got was some sort of a "server error" message and no download was possible. I fired up Garmin Express, held my breath for a couple of hours, and all went very well.

    I swore at it when it appeared it was taking the time to download the update twice, first to install the maps on my Nuvi and a second time to install the maps on my PC for Basecamp to use. When it finished up I realized that it had not taken any more time than using MapUpdater had taken in the past. I'm assuming MapUpdater actually did the 2 downloads but you couldn't see it happening and that's why it always warned you that downloading to the device and computer option would take longer than just updating the device.
  • sussamb 936 Points
    edited February 2014
    I've seen recent reports saying MapUpdater is working, so it may just have been a blip along the line somewhere. There was never a problem with it downloading the CN EU map, just seemed to affect the CN NA map download for a while.
  • I kept an eye on the download and basically what GE does is that it download the files to create the .MAP file to send to the GPS along with the SID, DB, etc files and then downloads the rest of the files necessary to install it in the PC. So its not a full download both times. Mapupdater would just download the whole package from the getgo.
  • Aviator327 91 Points
    edited February 2014
    When I installed the map to my 1350 this morning GE installed it to the "Lower 48" which is the format I have been using the past several years for my 1350 and 1490T since the internal memory is only 2gb. I have a 8gb Micro SD card in the 1490T for the Large JCV file. @sussamb, Thanks for providing that link also.
  • alanb 557 Points
    @sussamb - I have seen those same reports that some people are getting MapUpdater to work. But I tried it again this morning with CN NA 2014.4 and I am still getting "An unexpected error has occurred ..." message. This may just be some obscure problem with this version of the NA map, and I doubt that Garmin will have any interest in looking into it. But it will be interesting to see what happens with the 2015.10 update.

    I wonder if this is just a problem with the Windows version of Mapupdater, or if the Mac version also fails.
  • kemeyer 0 Points
    edited February 2014
    Aviator327 - I like the idea of putting the Large JCV file on the SD card. On my 1450 I've been going into the hidden directory to replace the small file with the large file. What’s the trick to getting the Garmin to use the file on the SD card?

    Never mind... I found details in another post (Internal memory vs memory card in 755T) that tell me what I need to know, assuming it also applies to the 1450.
  • sussamb 936 Points
    @alanb I know one of the guys on the Garmin forum got MapUpdater to work with the CN NA map ... on a Win7 machine. Not sure if there is any issue with the mac versions.
  • I too am unable to get MapUpdater to work, it has always worked on all previous map versions for me. Yesterday I got the same message as alanb "An unexpected error has occurred". Today I received a different message, I now get an error message of "a connection to the server could not be established. Please assure you have a connection to the internet and try again".

    I'm using XP SP3 with all Net Framework up to date. I've disabled my Anti Virus and Firewall but to no avail.

    Well I do have an internet connection and if I open Garmin Express all is working as well as WebUpdater. I certainly hope this is just an issue with 2014.40 and not Garmin's way of making Mapupdater obsolete. I am not a fan of Express.
  • I also cant get mapupdater to work on my WIN8.1 machine.
    I looked at the logs and the error seems to be that Mapupdater gets some kind of a string response from the Garmin Server for some query that is too long to what it expected and it makes it crash. :)
  • MapUpdater did not work for me. GarminExpress did.
    Both latest version, installed today.

    Mapupdater thought that I already had the .40 version. When I asked it to install (with different options) anyway, it gave me an error.
  • sussamb 936 Points
    Garmin have released Garmin MapUpdater v3.3.3 that apparently corrects the errors folks have been having.
  • alanb 557 Points
    I can confirm that MapUpdater v3.3.3 resolved the "Unexpected error" issue with the CN NA 2014.40 map update.
  • kinda late now for me. :)
  • alanb 557 Points
    edited February 2014
    Garmin Express updated to v2.5.2 yesterday on my computer. Express seemed to work OK after the update finished. But after shutting down my computer last night and restarting this morning, the User Account Control dialog popped up every time I tried to launch Express. This was the same symptom I had a while back when the dreaded sc.exe message from Express started happening. As far as I'm concerned, Garmin has never given a satisfactory solution to that problem (sorry sussamb, I realize you don't agree with that statement). So I got rid of Express (again!) and am hoping that MapUpdater will work when the next map update comes out.
  • sussamb 936 Points
    edited February 2014
    Well it's not that I don't agree ... it's that there's no indication it's an Express issue. It affects only a small handful of users, why it does I don't believe anyone knows. What I suppose would be useful would be if this new version of Express gave everyone the dreaded sc.exe message ... at least then the blame could be fairly laid at Garmin's door.

    I've just updated and no such message.
  • alanb 557 Points
    edited February 2014
    It is hard to blame it on the user's computer setup when 2 versions run fine, then the automatic update to next version introduces the problem ... and all 3 versions installed within a time frame of 48 hours. It's not like wholesale changes were made to the computer setup in that short time period.

    In any case, I just discovered another Garmin Express introduced problem. On my old 755T and 855 nuvis, I used Express with SD card cloning, and everything went fine. But on my 3597LMTHD I let Express update the unit directly, and in addition to installing the map, it deleted all the installed voice files in the Voice folder. For some reason, neither WebUpdater or myDashboard would list any of the voices as available for install/update (it must be they were still listed in the GarminDevice.xml). Fortunately I had made a backup just before the map update, so I was able to restore the files and everything is OK again. I had Express v2.4.5 when I did the map update.

    Other users on POI Factory are reporting this same problem of deleted voice files with various nuvi models.
  • So thats what happened with me Nuvi... I thought I had deleted them somehow. :)
    Glad I had a backup too.
    In any case GE is gone from my computer too and for next map update will try mapupdater and hope it works.
  • t923347 533 Points
    I used version 2.3.14 of GE to update the maps on my 3597 and all the TTS3 voices I had installed are all still on the Nuvi and working.
  • Has anyone managed to install 2014.40 onto the computer (for BaseCamp) using the latest version of GE? Mine keeps stalling during "configuring" with "4 minutes remaining" in the progress bar. I've tried every combination of with or without device and re-downloaning the mapset several times - it just won't finish installing onto the computer.
  • kenp 92 Points
    Yes. It worked for me this afternoon. New computer (Windows 8.1), ran around the web site a bit before I got communicator installed and downloaded GE, but once running it went smoothly. Basecamp was there and it worked.

  • I just finished installing 2014.14 using the newly released MapUpdater 3.3.3, and everything worked fine.
Sign In or Register to comment.
↑ Top