This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

CN NA 2014.40

2»

Comments

  • sussamb 829 Points
    IIRC an older version of Express also incorrectly deleted voice files, seems like the 'bug' has been reintroduced.
  • Sussamb, Could you provide the latest link to ver 3.3.3? I may want to use that to install my map to my 1490T. Thanks

    Garmin have released Garmin MapUpdater v3.3.3 that apparently corrects the errors folks have been having.
  • sussamb 829 Points
    Sure ...

    http://download.garmin.com/lmu/GarminMapUpdater.exe

    Mac is here:

    http://download.garmin.com/lmu/GarminMapUpdater.dmg

    Note links are still the same as before, just downlaods the updated versions.
  • Express deleted my voice files too. Had to restore them through the myGarmin Dashboard.

    Good thing that I read this thread, or I'd be futzing around with the device while driving.. trying to figure out why the voice prompts were not happening.

    That's it!! Express is gone from my PC.
  • That reminds me, it's been a while since I backed up my nuvi. Thanks, GarminExpress programmers, for reminding me. :)
  • Thanks - GarminMapUpdater v3.3.3 succeeded at installing 2014.40 onto my computer on the very first attempt. GE absolutely refused to accomplish the same task.
  • I'm really glad someone discovered the voice issue with Garmin Express and posted it here. While I was out and about today, when I finished my mission, for kicks and grins and to verify this issue, I told my 3597 to take me home. Much to my surprise it started giving me directions in Spanish. I checked quickly and for some reason Spanish was the only voice on the device.

    As soon as I got home I attached the 3597 to my computer and instead of restoring from a backup I just updated the language set and removed what I didn't want. Sure glad I found out about this before going on a trip and much to my surprise not being able to understand anything she was telling me!!!!!!!!

    Thanks again for the heads-up!!!!!!!!
  • sussamb 829 Points
    Garmin have issued v2.5.3 of Express, hopefully solving the problem with deleting voices.
  • Kind of makes me wonder if there was some change to the basic structure of the 2014.40 map files. Garmin has had to quickly release several updates of both GE and mapupdater just to fix numerous installation problems. I don't recall this happening to this extent with prior map releases.
  • t923347 532 Points
    Certainly not so much with MapUpdater but at one time GE was getting updated 2 or 3 times a week, map update or not.
  • sussamb 829 Points
    Now up to v2.5.6
  • Man, if Netgear published firmware corrections as frequently as Garmin publishes software fixes I might have had confidence that they were going to fix the problems in the R7000 Router and I might have kept mine!

    I wonder if GE v2.5.6 fixes that annoying "sc.exe" needs your permission to run window!!!!!!!!!!
  • sussamb 829 Points
    Never had that ... Seems it only affects a few.
  • alanb 556 Points
    That may be true sussamb, but if you are one of the "few" it is a real pain. And Garmin's recommendations for fixing the problem don't work for everyone. After I made the changes recommended by Garmin, the program still wouldn't start up. Then even the uninstaller wouldn't work and I had to resort to manually deleting the Express files and going through the registry with regedit to get rid of Express. After going through that, I avoided Express until I ran into the problem that Mapupdater wouldn't install CN NA 2014.4. So I took a chance and installed Express 2.4.4. I didn't have the sc.exe failure again. And Express actually worked pretty good for updating the map on my 3 nuvi's except for deleting all my voices on the 3597. I think I was up to 2.4.5 when that problem occurred.

    Maybe my situation was unique, I really don't know. But in any case Garmin shouldn't so easily dismiss those "few" users that are having the problem. To be fair to Garmin, I will admit that I didn't try calling Garmin support. Maybe they could have helped.
  • sussamb 829 Points
    Let's hope you're right and that the problem has gone with v2.4.4 onwards ...
  • I was still having the "sc.exe" issue with GE v2.5.3 and I'm running Windows 7 Professional. Interestingly, for me, after each GE version update I would experience the "sc.exe" popup for the next 2-3 startups and then it would be gone until the next GE update. I updated to v2.5.6 right after sussamb posted about it today and then I immediately did a restart and didn't get the popup. Maybe, just maybe, that issue is no more, we'll see!!!!!!!
Sign In or Register to comment.
↑ Top