This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Help, new Basecamp upgrade does not run

Basecamp decided to upgrade right as I am about to go on a 3000 mile motorcycle trip! Upgraded to 4.3.3 I think and has a run error of MSVCR90.DLL can't be found. Help please I need my routes.

Comments

  • t923347 533 Points
    Garmin's advise is to:

    Anyone getting a Windows file .dll error message after updating BaseCamp on a Vista, 7, or 8 computer should uninstall BaseCamp then delete the C:\Program Files (x86)\Garmin\BaseCamp folder. Reinstall BaseCamp and the error should not return.
  • I don't have that folder and I downloaded the new one full from the web site and it fails with the error. What now.
  • MSI error... file not found.
  • sussamb 954 Points
    With the MSI error it means your windows installer isn't up to date, you can update it here:

    http://www.microsoft.com/en-us/download/details.aspx?id=8483
  • I have windows 7 32 bit... which one do I need??? thanks.
  • That is date 2008!!!!
  • Boyd 2035 Points
    Another approach would be to downgrade Basecamp to an older version that does work. If you have a backup of your computer, that shouldn't be too hard. If you don't have a backup (and you really should), then old versions are archived here:

    http://gawisp.com/perry/mapsource/
  • sussamb 954 Points
    I have windows 7 32 bit... which one do I need??? thanks.
    On Win 7 you don't ... must be another issue, try running the .net repair tool as a problem with .net can cause BC install to fail:

    https://support.garmin.com/support/searchSupport/case.faces?caseId={c9ab5190-3cd7-11e3-f27b-000000000000}

  • Sorry.... still fails.
  • sussamb 954 Points
    Try reverting to 4.2.5 and see if that runs

    http://www8.garmin.com/support/download_details.jsp?id=7161
  • None of the previous version install now. Same error.
  • sussamb 954 Points
    Are you doing the following:

    Anyone getting a Windows file .dll error message after updating BaseCamp on a Vista, 7, or 8 computer should uninstall BaseCamp then delete the C:\Program Files (x86)\Garmin\BaseCamp folder. Reinstall BaseCamp and the error should not return.

    If you're still having issues I'm not sure what else to suggest.
  • Just a program files directory (32 bit). I removed Basecamp fully. No joy.
  • t923347 533 Points
    edited June 2014
    *
  • It's an "MSI Error, File not found"
  • And I do have that .dll file on the laptop, 5 instances.
  • truckinguy 117 Points
    Like I've posted before but will again. My Dell won't take the new 4.3.3. No matter how I have tried. It installs but the fonts size and order are corrupted. I find I can reload (after uninstalling 4.3.3 and deleteing basecamp folder) the 4.25 fine. That version works fine.
  • sussamb 954 Points
    It's an "MSI Error, File not found"
    Well it's definitely a Microsoft Installer Error then ... how you fix it I have no idea.

  • Only problem is it is only Basecamp that gives the error. No other program.
  • sussamb 954 Points
    Well that would be true if we all had issues like that but my 2 PCs updated without any problem. Didn't get any errors.
  • truckinguy 117 Points
    Only problem is it is only Basecamp that gives the error. No other program.
    True...I have many programs... Garmin has dropped the ball on this one somehow.. .when 4.25 works but not 4.3.3 that is there problem not mine.
  • l henry 192 Points
    HP computer
    Windows 7

    I have similar problems with BaseCamp v.4.3.3. No error message, but font size and display corrupted.
  • sussamb 954 Points
    Not sure that's a similar problem :-)

    In what way is it corrupted? Are you able to post a screen shot?
  • truckinguy 117 Points
    I could post a jpg of both the 4.25 ver and 4.3.3 in a screen shot but I don't know how here. I can email you one.

    I have win 7 pro 64 bit.
  • Chris_Sav 132 Points
    edited January 14
    If you email them to me at [redacted] I'll put them on one of my sites and anyone can see them.
  • t923347 533 Points
    I could post a jpg of both the 4.25 ver and 4.3.3 in a screen shot but I don't know how here. I can email you one.

    I have win 7 pro 64 bit.
    Put the photos in a site like Photobucket.com and then use the "Image" tab in the line at the top of the box you use to input your posts. The one that shows B I U S C etc. The tab to the right of the C is the image tab

  • truckinguy 117 Points
    I had photos in photo bucket but they've changed now. I sent the pic's too Chris. I sent 4 pictures. 2 that are of each of the main screen of Basecamp with the corrupt columns on the left of the 4.3.3 and 2 screen shots of each version of the properties tab for waypoints showing the much smaller text and fields. Also text in other areas are small as well.
    I did the screen shots with Win7 snip it tool. All photos are of the whole screen of my notebook. So every one is the same area as the other.
  • Chris_Sav 132 Points
    edited June 2014
    Never used a notebook (box brownie camera syndrome!!) have you the latest graphics drivers and have you tried a different screen resolution to see if the same happens (doubt it will solve it but would suggest drivers if not)?
  • truckinguy 117 Points
    edited June 2014
    No I won't fool with changing the settings. They are the best for my screen and software combos. I have a 1920 x 1080 screen and all drivers are up to date.
    Like I said It is the only program out of many I use that does this. I'll leave it at 4.25 for now as I only us BC to transfer from my Montana to convert for MS use.
  • l henry 192 Points
    With reference to my post above, my screen image is as pictured in "4.33 main menu" (Truckinguy's pictures)
  • truckinguy 117 Points
    With reference to my post above, my screen image is as pictured in "4.33 main menu" (Truckinguy's pictures)
    We have something in common.... I guess. I have a Dell Latitude E6530 win 7 pro 64 bit. FHD screen.
  • menhir 115 Points
    edited June 2014
    Just to add to the noise...I received the same error message when I updated Basecamp a week or two ago.
    There was no help for it...nothing worked. I did some searching and it looks like they're blaming Garmin...Not Windows...but darn if I can find the site where I read that.

    Anyhoo...Uninstalling and reinstalling was the only solution that worked. I have a Dell Latitude E6410 running Windows 7. No problem: the reinstall worked the first time.
  • truckinguy 117 Points
    Uninstalling doesn't work for me. Tried it a few times. Go figure.
  • sussamb 954 Points
    Guess you'll need to stick with 4.2.5 for now ... 4.3.3 works fine on my Win7
  • New 4.3.4 has the same issue, MSI error.
  • sussamb 954 Points
    Which OS? Updated fine on my Win7 PCs.
  • Win 7 pro all updates.
  • sussamb 954 Points
    edited July 2014
    You might want to try updating your MSI, that could be the issue. No idea how you do that though, too techie for me.
  • I found the solution on the web:

    SOLUTION:

    download BaseCamp.exe file, than use a compress tool like 7-zip

    right mouse click on the file to open file and see elements in the exec file

    look for the BCMAIN.msi file, double click, it will then install,

    after you can then go back to the normal BaseCamp.exe

    it will then install nicely

    Yes it installed just fine now.
  • sussamb 954 Points
    Great :-)
  • Updated to the newest maps and this worked just fine too.
Sign In or Register to comment.
↑ Top