This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

garmin express unable to connect

I have a Garmin Nuvi 1340 LMT and am unable to update the lifetime maps. Whenever I try to connect with Garmin Express to update, I get the message 'unable to connect with Garmin services'. Repeated new downloads of Express and trying through 'settings' to get upgrades says all is up to date (v3.2.18.0) but still it is 'unable to connect with Garmin services'. Am having very little luck trying to get through to Garmin support by email and the phone response has sent me a check list which is of no help. I have fitted a microsd card, but still cannot get any connection with garmin to check on updates, although the Nuvi keeps telling me I need to update the map. Getting more than a little frustrated ... any suggestions for solutions? Cheers, Ian


  • t923347 533 Points
    I wonder if you need to install the latest Garmin Communicator plugin on your computer. It can be downloaded from
  • Just tried that, and it took me through to download Garmin Express once more! with the same result ... unable to connect etc. Thanks for the thought, though. Any more ideas? Cheers
  • sussamb 961 Points
    This advice is given on the Garmin forums for situations like yours:

    In some cases depending on how the security software is setup along with User Account permissions can cause issues with what has been described. One thing you can try is forcing access to allow the Garmin Core Services to be allowed through to the internet. These steps may help correct some issues that you may be having.

    1. Press the Windows key+R
    2. Type "services.msc" and press Enter
    3. Locate and right-click Garmin Core Update Service
    4. Click Properties
    5. Click on Log On tab
    6. Select This account
    7. Type "Network Service" in the Account field
    8. Remove all text from both password fields
    9. Click Apply, then click OK on the next three prompts
    10. Right-click Garmin Core Update Service and Click Stop
    11. Right-click Garmin Core Update Service and Click Start

    If you have tried the above steps and nothing changes, and you have logged in as an administrator account disabled security and nothing changes you may need to use a different machine to perform the map update. Some third party program or feature on your computer is blocking the Garmin Express software.

  • Thank you for that. I have tried those steps, and it still fails to connect with Garmin Services. I do not understand why it manages to judge that 'your device software is up to date' and registers that the device is connected, and yet fails to connect with garmin services. Surely if it can check on the state of the software on the device, it should also be able to check on the state of the map content and enable me to download updates ... is there a step here that I am missing? I am using an up to date firefox browser and up to date Norton antivirus, so surely this combination is not unusual ... what could be preventing the connection?
  • privet01 231 Points
    edited September 2014
    There is a sub-forum over here devoted to issues with Garmin Express both on a Mac or PC. Occasionally there is a person there that actually seems to be connected with Garmin.
  • privet01 231 Points
    edited September 2014
    You might also try Garmin Mapupdater. It was replaced by Garmin Express, but it worked earlier this year for me when I updated the maps on my nuvi. I don't have the link to it on this computer, but if you can't find it, let me know and I'll post it when I get to my other computer.
  • sussamb 961 Points
    Just replied in the other thread the OP opened. MapUpdater is here:
  • Sorry about the double up with this discussion -- I will try to continue it in the Garmin Nuvi forum.
  • Thanks for all that.Have just used the Garmin Mapupdater and it worked well. At last! Thank you all for your tips and advice, and the links to the necessary bits and pieces. Very helpful and much appreciated.
  • And now there's a twist ... having managed to download through Mapupdater, I tried the Express just out of interest, and lo and behold, it suddenly wants to work for me! A good result all round. Hopefully Express continues to be a friend to me ...
  • sussamb 961 Points
    Sounds like there may have been a problem with your ISP earlier ... either way great it's now working for you.
Sign In or Register to comment.
↑ Top