This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Garmin 390 LM 80% error message

After following the many forum discussions on the inability of the Zumo 390LM not calculating the route after an update in June, (2017) and the inability of the tech support at Garmin to resolve the issue. I would be interested in how many people are having the same issue, and would they consider joining a Class action, against Garmin?


  • Boyd 2009 Points
    What is the "80% error message"? Are you saying that the unit worked properly before you updated the software in June? If so, it should be a simple thing to re-install an earlier version of the software. Old versions are archived on this site:

    Choose the correct one for your device and download. Not personally familiar with the Zumo, but with Garmin's Nuvi series, you would change the name of the downloaded file to gupdate.gcd, then copy it to the invisible .System folder on the GPS. When you restart the GPS, it should ask if you want to revert to the old version of the software.

    Seems like this would be a more practical way of getting your Zumo up and running again, as opposed to a lawsuit that would take years and probably disappoint you with any amount you might collect.
  • shrory 0 Points
    Hi Boyd
    unfortunately the 309 LM is not listed in that list. i have, as have many others, had problems with the product since the update, and Garmin will not acknowledge it. however, it is well documented on other forums. perhaps its my suspicious mind, but the 390 has just been superseded by the 395.
  • Boyd 2009 Points
    Your thread title says "390" but now you have written "309". Which is correct?

    The zumo 390 is on the list, you just need to understand the "shorthand" that is used. The files starting with "zumo3x0" would be correct for the Zumo 390. So, for example, this file would be firmware version 4.10 for the Zumo 390. According to that site, version 4.20 is the newest, so if you are currently using firmware 4.20, this file would let you roll back one version.


    Or you could also use one of the older versions. Check to see what you are currently using and if it worked better before the update, go back one version.

    I just don't think you will get much satisfaction from a class action suit, but don't let me stop you. You might get some kind of small refund or credit 5 or 6 years from now. Last year I got a check for about $20 and the letter said it was a class action settlement for HughesNet satellite customers. I don't remember anything about the lawsuit, but it had been 8 years since I was a HughesNet customer. Evidently it was a settlement for their internet speeds being lower than advertised, LOL. :)
  • shrory 0 Points
    390 is correct, found the file you mention, Thank you, tried a couple of those file, zumo3x0_GCDFile__420.gcd 2016 and a 2015, removed the original file GUPDATE replaced with the older version, but after a reboot it did not ask about which version I wanted, and when connected to Express it tells me my software is uptodate?
    any ideas, getting more response from you that Garmin support.
  • shrory 0 Points
    played with it some more and got it to ask which version, told it the older one, however, still not calculating beyond 80% for the route, which is only 120 miles away. one point that is confusing it will calculate a closer address, say 90 miles away, lots of room internally and externally
  • Boyd 2009 Points
    I would also do a hard reset on the Zumo. Not sure if this is the same as the Nuvi, but I suspect it may be:

    The reset oftem clears odd problems like what you have described.
Sign In or Register to comment.
↑ Top