This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

NuviCam LMTHD won't connect to Win 10. Goes straight to navigation mode. Won't go into storage mode

I have tried everything to get my NuviCam LMTHD to connect to my Win 10 laptop.
Nothing works.
Yes it is a data cable.
Yes it is a Garmin cable.
Yes the cable works on my Win 7 machine.
Yes the ports on Win 10 machine works with other USB devices.
Yes I have the latest firmware 3.60 on the Garmin NuviCam.
Yes I have the latest Garmin Express installed.
Yes I've tried updating drivers but it's pretty hard to do when the Garmin isn't even found in Device Manager, EXCEPT ONE TIME LAST week I was able to get it recognized. I was messing around with the USB ports trying to figure out why it wouldn't work and decided to plug a USB stick into the other port. I then told the USB stick to update its driver and at the same time the Garmin was miraculously found. I was able to download the maps from the Garmin to my Win 10 machine into Basecamp, so the Garmin was fully functional. I was able to copy waypoints and routes from Basecamp to the Garmin. Then I shutdown the laptop, restarted, and the Garmin was gone.

The Garmin was gone, never to be found again, EXCEPT I can force the Win 10 machine to find it by doing this odd maneuver. I can plug the Garmin into the Win 7 machine's USB 3.0 port. At that time the Win 7 machine will put the Garmin into data mode, as evidenced by the icon on the Garmin's screen. Then I unplug from the Win 7 machine and hurry and plug it into the Win 10 machine and walla, the Win 10 machine sees the Garmin and installs it. Of course this is useless to me since I won't always have access to my Win 7 machine while I'm traveling. I need to get this Garmin to work with my Win 10 laptop. It is a Dell XPS15, and was recently purchased a few months ago. Dell cannot help, Garmin says it's a Dell problem, Dell says it's a Garmin problem, I'm fed up with the finger pointing.

I have attempted to update all the USB drivers and Windows 10 tells me I already have the best drivers.

Can anyone help?


  • Zemartelo 207 Points
    Did you try to hard reset the nuvi?
    Did you change it to MTP settings in the secret service menu?
  • sussamb 829 Points
    Actually it's best to set it to mass storage mode, mtp is the default mode. Win10 has issues with some mtp devices.
  • I have not tried a hard reset as I didn't want to lose all the locations I have stored. I'll have to figure out how to back all those up in Garmin BaseCamp and then do the hard reset.

    If mass storage mode works best, I'll put it in mass storage mode. So far, neither have worked for me, but it won't hurt to leave it set on mass storage mode as a default.
  • Boyd 2009 Points
    All your saved locations should be in the file named Current.gpx. You can just copy that to your computer, do the hard reset and shut it down. Rename the file Temp.gpx and copy it to the GPX folder, then restart the GPS and your saved locations should all be restored. As a final step, you should delete the Temp.gpx file from the device.

    Of course, you can also do this with Basecamp if you prefer, and Garmin Express also has a feature for this.
  • Will this lose my maps? I have them in Basecamp I just don't want to have to re down load them as I have country internet and it literally takes ALL day.
  • t923347 532 Points
    A hard reset will not disturb your maps.
  • Boyd 2009 Points
    edited October 2017
    The hard reset will delete your saved locations, restore all the menus to their defaults and clear out your search history. Unfortunately there is no way to restore the search history and you will have to re-do all the menu settings that you have customized.
  • Since I'm going to be needing this Garmin in the next month, I think I'll hold off until December. I don't want to disable the entire thing by accident. :)
  • Chris_Sav 127 Points
    Have you got an SD card in the device? have you tried connecting without the SD drive?
  • I have tried so many things, I can't remember if I tried connecting without the card. I'll have to try this. I have discovered a workaround but it's kind of a pain, nevertheless at least it "works".

    I enabled my laptop's USB ports for charging devices when the laptop is off. I enabled this is the BIOS. Now, if I plug the Garmin in to the USB port before turning on the laptop, the laptop will put the Garmin in mass storage mode. But....I have to then unplug it and turn the laptop on, and once the laptop is on I plug the Garmin back in to the USB and the computer recognizes it as a mass storage device. Luckily the laptop boots up fast enough so that the Garmin doesn't turn itself off and out of mass storage device mode in the time it takes the laptop to boot.
  • Chris_Sav 127 Points
    I had similar problem a while back with my Montaba refusing to go into mass storage which turned out to be a troublesome SD card. The Montana booted into mass storage fine without it.

    Probably won't help you but worth checking.
Sign In or Register to comment.
↑ Top