This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Device update 4.40 won't install

I have a DriveSmart 61 and a Drive 61. No issues updating the DriveSmart 61 to latest map and updates.

The Drive 61 will not install the 4.40 device update. I've had this same issue with previous device updates on this Drive 61, but I always seemed to get them installed at some point. No luck with this one, stuck on 4.10.

Does anyone know of a direct download of the device update v4.40 that avoids using Express, or even the 4.30 update which I had skipped?


  • I should probably add that I've tried installing through Express. It goes through the process of downloading, then installing, but it never completes installation and quickly jumps to the update screen showing the update is still needed. Rebooting device and computer does not help. Also used Web Updater through Basecamp, which showed that it successfully installed, but still no joy. Device about screen shows version 4.10.
  • Had to do a lot of fussing around, but eventually found enough posts to figure this out. I tried putting renamed file into Garmin and Garmin/NewFiles, both with no success. Changed my File Explorer settings to show System files, still couldn't see the .System folder. Then I found a message by Boyd in this thread:

    which explained going into MASS STORAGE MODE, which then displayed the .System folder. Copied gupdate.gcd into .System, restarted GPS and it ran the update. Went back into settings and reverted to Auto.

    Thank you very much. I've bookmarked links for future use.
  • Boyd 2043 Points
    Glad you found it helpful. Actually, I think there's a better way to access the hidden .System folder. I don't like changing the control panel settings in Windows, because then it shows lots of files that I normally would prefer to have hidden. So this is the simple technique I use now - just click on your device, then manually type ".System" into the address bar in Explorer. This will put you in the hidden folder without changing any settings.

    Of course, you must enable mass storage mode on the device before this will work.

  • That is cleaner. No messing with the Explorer settings and having to revert back.

    Thanks again for the helpful posts (from you both!). I couldn't have gotten this to work without your help.
Sign In or Register to comment.
↑ Top