This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

express not recognising nuvi

Hi Bought a new lap top with win 10 , have downloaded express but it doesn't recognise my nuvi 2569 Express is still ok on my old win 7 lap top. What am I doing wrong. ?

Comments

  • sussamb 798 Points
    edited January 8
    Are you using usb3 ports? If so try usb2 port if you have one. Also Win10 can have issues with mtp devices, try switching your nuvi to mass storage mode. Detail is here

    http://forums.gpsreview.net/discussion/27560/nuvi2515lm-wont-connect-to-my-pc
  • J.D 82 Points
    Thanks Sussamb, my old win 7 lap top recognises it no problem but the new win 10 does not show it at all so its not a garmin problem , ive tried it in all usb2 ports. The ports recognise printer and flash drives but not the sat nav. Ive only just bought the win 10 so am unfamiliar with where to look. Surely if it connect to the old lap top then it should be ok with the new one
    ,
  • sussamb 798 Points
    That's probably then the mtp issue, switch to mass storage mode and try.
  • J.D 82 Points
    Not sure if I understand, if the pc doesn't recognise the sat nav how do I switch to mtp. I think as I want to be able to still use my win 7 as well it might be better to leave as it is.
  • Boyd 1980 Points
    edited January 8
    You do this on the GPS itself, before connecting it to the computer. By default, a Garmin GPS appears to be a "MTP Device" when connected to a Windows computer (but not a Mac). This makes it behave more or less like an iPod or other music player, and only allows you to access a limited part of the filesystem. Switching it to Mass Storage mode will make it behave like a USB flash drive, with full accesss to everything.

    Start NUVI by itself and go to Volume Screen.

    Press the upper right hand corner of screen for 10 seconds.

    The Developers Screen will pop up

    Scroll down to MTP SETTINGS

    Change from AUTO DETECT to MASS STORAGE

    Shut down NUVI and hookup to Computer USB cable
  • sussamb 798 Points
    Detail is also in the thread I mentioned above :)

    Note it'll still work with Win7 in mass storage mode.
  • Boyd 1980 Points
    I don't see any real downside to leaving the device in Mass Storage mode. I do it will all my Garmin Devices. Just don't start messing around with files that you don't understand. ;)
  • sussamb 798 Points
    Agreed, me too.
  • J.D 82 Points
    Ok, ive got the developers screen, first it says what version it is etc, then pressing next it gives Audio test page ,then Bluetooth test page, then I just get blank coloured screens . I cannot see mass storage. ???
  • jangeo67 86 Points
    go back to first screen, scroll down
  • J.D 82 Points
    edited January 9
    post deleted
  • alanb 539 Points
    edited January 9
    On my 3597, pressing the upper right corner of the screen takes you to a different set of diagnostic screens that does not have the developers menus. To get to that, I go to the map (navigation) screen and press on the speed indicator which takes you to the trip log screen. Then press and hold the speedometer to get to the developers menu. From there, you can scroll down to get to the MTP setting.
  • J.D 82 Points
    Ok found all that in the end and changed to mass storage ( its under Configuration and settings) but still nothing. Still works on win 7 but win 10 does not show it as a device so I guess its a lap top problem not a Garmin,
  • Boyd 1980 Points
    edited January 9
    It could be an issue of your laptop not providing enough current through the USB port to operate the Nuvi properly. I seem to recall discussing that in the past. One way to troubleshoot that would be connecting it to a powered USB hub (if you have one) and see if that helps.
  • J.D 82 Points
    edited January 10
    The HP lap top recognises my printer and a pen drive, its just the Garmin for some reason.
    Thanks for all the replies
  • Boyd 1980 Points
    The flash drive requires very little power to operate, and the printer gets its power from the wall outlet. But the Nuvi depends on the USB port to operate all its circuitry and light up the screen. :)
  • alanb 539 Points
    edited January 10
    In spite of the advice normally given, if you have a USB hub try connecting through the hub. I once had a Windows computer that would not recognize my nuvi devices when connected directly to the USB ports on the PC chassis. But if I put a USB hub in the middle, they would connect just fine even though the hub was only powered through the USB port (no external power) … go figure. I figure it had to be a driver compatibility issue for the native USB ports. The hub used a different set of drivers.
  • Boyd 1980 Points
    Have not used one of these myself, but if you really want to troubleshoot this kind of problem they would be handy. There are many similar products, but these two were recently recommended by members at Laptop GPS World and are inexpensive. Would be interesting to see the difference in voltage/current when plugging the Nuvi into the laptop, desktop, hub, etc.

    image

    www.amazon.com/PowerJive-Voltage-Multimeter-chargers-capacity/dp/B013FANC9W

    image

    www.amazon.com/USB-Charger-Doctor-line-Voltage/dp/B00S80CMBO
  • J.D 82 Points
    Thanks again for the replies, I don't have access to a powered hub ( never even heard of one before ) What you say makes a lot sense. I'll have a think about it.
  • tried my Nuvi 2797via one of these meters plugged into my USB3 port with a fully charged GPS and it shows 4.85V with a current starting at 0.880A (880 mA) settling down to 770mA.
    That could be a hefty drain on many a computer port and it is recommended that the GPS be fully charged before connecting to a PC.
    Lowering the screen brilliance to about 50% reduced the consumption to 330mA, this could be a simple solution if power consumption is the issue.
    I will do a bit more experimentation as I have experienced many false start attempting Nuvi connect to W10 and just persevered, maybe it is time to track it down.

  • J.D 82 Points
    That's the answer Kevin. I lowered the screen brilliance and the Win !0 immediately recognised the Garmin . All sorted , thanks everybody for your help.
  • alanb 539 Points
    That is a solution I would have never thought of … good find and something to remember.
  • Boyd 1980 Points
    Funny.... on the older Nuvis that used an active cradle with the special connector, when you connected them to the USB port (either computer or power supply), the screen operated at reduced brightness (even though it indicated 100%). So apparently Garmin used to understand this issue. Seems like it would be a simple thing to automatically reduce screen brightness when the device goes into mass storage mode.

    Thanks for posting your findings. It does seem to be an issue of the computer not providing enough power (or, depending on your point of view, an issue of the Nuvi drawing too much power). :)
  • ruggb 81 Points
    Boyd said:

    You do this on the GPS itself, before connecting it to the computer. By default, a Garmin GPS appears to be a "MTP Device" when connected to a Windows computer (but not a Mac). This makes it behave more or less like an iPod or other music player, and only allows you to access a limited part of the filesystem. Switching it to Mass Storage mode will make it behave like a USB flash drive, with full accesss to everything.

    Start NUVI by itself and go to Volume Screen.

    Press the upper right hand corner of screen for 10 seconds.

    The Developers Screen will pop up

    Scroll down to MTP SETTINGS

    Change from AUTO DETECT to MASS STORAGE

    Shut down NUVI and hookup to Computer USB cable

    NOTE: Screenshots must be disabled first.
  • t923347 426 Points
    ruggb said:

    Boyd said:


    NOTE: Screenshots must be disabled first.

    True, but screenshots are disabled by default on all Garmin GPS units I have owned (since 2005), so this wouldn't be an issue for most users.
Sign In or Register to comment.
↑ Top