This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

North America NT 2019.30

North America NT 2019.30 maps are out. Discuss... :)


  • Boyd 2002 Points
  • Exactly! :)
  • Anyone have the full version for junction view? they can upload?
  • teejay 91 Points
    Yes, Just updated DriveSmart 50 LMT with 2019.30
  • North America NT 2019.30 maps are out. Discuss... :)

    I updated 2595LMT to from 2018.xx to 2019.30 before leaving on a 1400 mile drive and was a disaster. "Memory is Full.", Memory error", " Cannot calculate route..". I messed around with it - reload.. no luck.
    Logged a call with support.

    They got in touch and :
    I explained that I had had the 2595 for 2 years and thought it strange that when I connect it to PC it sees ' the device' and ' the mmc card' in the GPS as TWO devices.. "Isn't that a problem?" I asked. ( I'm a retired computer guy) "Is THAT why I am getting memory full errors? Not enough working space to load new version.." etc.

    'NOPE. That's not a problem' was the reply.
    20 minutes later I was told that my GPS was hopeless.

    "WHAT ARE YOU TALKING ABOUT! It was fine before map update!
    I hung up.

    Show hidden files/ Folders. Select All, Copy to my external drive and went to dinner.

    A few days later back at it. Garmin Express shows 2595.
    I went to friends house/ Downloaded Garmin Express - plugged in GPS and it displayed "2595+mmc " Aha. I'm guessing ON MY PC it saw no change in s/n from the first time I plugged it in WITHOUT an mmc card when new and couldn't ran out of working space to finish load of new map. At completion It kept prompting me to to load 2016 gpsprom.img file not 2019. Where is it getting THAT?
    Searched registry and I see two sections:
    One related to OLD map and one for new. As if two devices.

    Open GE, deleted device, rebooted.
    Plugged in GPS and it saw 2595+mmc.

    OK, I'll deal with this later.
    Drove here using my X year old 265T.

    At end of drive backed it up here and did a hard reset on 2595.
    Told it to drive Wash DC. ... 10%,20%,30%.. worked fine.

    Summary: for ME I think issue was Garmin Express install saw device as no mmc and loading a new map created new pointers. 2019 map install process saw 'different device' (with mmc???)
    On a different PC - seeing the GPS AND MMC card as one device, map install was OK.

    BTW, after the hard reset I didn't need to 'change the map' . that new version was still loaded in GPS and WORKED. So why the confusion during install? 2016 pointer?

    Now messing with restoring Favorites and POI's etc.
    Original 265T GPX folder has a lot of GPX files ..
    I have waypoints like FL2CA.gpx, NH-FL , CA-WV , gpxfile2010027121842.GPX.

    Can I just drag and drop into 2595 GPX folder ?

    ALSO - 2595LMT now shows no hidden system folder on device.
    Because it is using mmc card??

    Found no help at Garmin support for most of technical questions.
  • Boyd 2002 Points
    edited January 2019
    I think the most important lesson is not to update your GPS just before going on a trip. I learned this the hard way before, and so have many others. :)

    I couldn't really follow all your points, but here are my thoughts. First... what do you mean by "MMC" card? I think the correct term is "Micro SD card" (or Micro SDHC card probably).

    Simply showing hidden files/folders will not reveal the hidden .System folder, because Windows considers it as "protected operating system files". I suggest you use this technique


    As a retired computer guy, I'm sure you understand the difference between RAM (Random Access Memory) and Mass Storage (such as a disk drive). Unfortunately, this gets confused easily today, since disk drives are being replaced with Flash Memory, so the term "memory" becomes ambiguous. But I think the message you got about "Memory error, cannot calculate route" is a reference to a lack of available RAM, which is used for calculations. So there is nothing that you can do in that case, except simplify your route.But this is also a classic example of the sort of "bogus error" that is often cured by performing a hard reset.

    Unless I don't understand you, there is no problem with your computer seeing the 2595 and the SD card as separate devices. They *are* separate mass storage devices (disks). Now Garmin's software should understand that they are related, but that's another matter. I don't like Express and try to avoid using it as much as possible, so maybe someone else can comment on your issues with that program.

    Regarding the favorites and .gpx files, I just made a lengthy post here about how they are treated.

    But basically, yes you can just drag them to the .gpx folder on your 2595. The first time it starts, all the data will be imported and following that, you can (and should) delete the .gpx files. Now that applies to favorites (aka waypoints or saved locations), POI's may be treated differently, I don't use those. So maybe someone else can help with that.

    I'm guessing that a good part of the other problemis are related to the fact that you never actually accessed the hidden .System Folder. And it's also quite possible that if you had done a hard reset before your trip, everything would have been fine. :)
  • It's important also to delete anything that you'll never use. Things like other languages (text, voice), vehicles, etc. They all take up space. I also had a 2595, and never had a problem with updates. They have 8GB memory, which is currently the largest Garmin offers. Delete everything superficial you'll never use, and you'll be fine.
  • alanb 557 Points
    To see the hidden .system folder, you need to change your 2595 from the default MTP mode to mass storage mode, and of course change your computer folder settings as Boyd said. Maybe you have already changed your device to mass storage mode but I didn't see from your post that you had.
Sign In or Register to comment.
↑ Top