This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

map download problem on my Garmin GPS


Can anybody help pls.

I downloaded Seychelle map to my Garmin Drive 50 GPS with Garmin base camp software.

My map already shows on GPS device : Seychelle v2.0, Seychelle - Africa - GPSTravelMaps

Garmin Base camp software on PC shows the Sychelle map in detail

Mapinstall on Garmin base camp shows: Seychelle v2.0 already deployed 56kB

However the Seychelle map file on my PC is 1020 kB.

Garmin GPS screen is empty for Seychelle.

It seems only partial download is succesful. ( 56kB vs 1020 kB)

I tried to delete and re install the map software 3 times.

No change.

I also applied master reset on my GPS. Does not help.

Thank you in advance for any suggestions.



  • Boyd 2027 Points
    edited April 2019
    Did you use the current versions of Basecamp and MapInstall for WIndows? Basecamp 4.7/MapInstall 4.2 were introduced in May 2018, and they do not work correctly. MapInstall will not send a map to your GPS properly, the results are pretty much as you described.

    Of course, something else could also be wrong, but if you used the current version of Garmin's software, then it just isn't going to work. Garmin doesn't really seem to care about this, because the problem is well-documented, yet they still have not fixed it. Garmin has announced they have ceased development of Basecamp.

    So your only options are to install an older version of Basecamp/MapInstall or else use Garmin's older Mapsource software, which still works properly. See this thread at GPSFileDepot for more information.
  • gabor 1 Point
    thanks for your info.

    I have 4.7. !!! So I will delete and try to install previous version. I will let you know the result. thanks
  • gabor 1 Point
    Bingo !!! Problem solved. I installed basecamp 4.2.5 and everything is OK. Thank you very much !
  • Boyd 2027 Points
    Happy to help. :)

    And shame on Garmin for not fixing this major bug that has caused so much trouble for the past 11 months. X(
Sign In or Register to comment.
↑ Top